LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   booting the kernel *hang* (https://www.linuxquestions.org/questions/linux-newbie-8/booting-the-kernel-%2Ahang%2A-53672/)

ANewbie 04-06-2003 06:17 AM

booting the kernel *hang*
 
Hi!
I've just installed redhat 8.0. The installation went fine,
but the system hangs just after LILO has uncompressed linux and the message ok, booting the kernel appear.

I can boot from my boot diskette, but it is not very fast, and I would rather boot the normal way.

I've searched the internet and (this forum) but did not find anything, or understand (hey! I'm a newbie, remember that), that solved my problem.

Any suggestion of what the problem could be or how I should do?
Happy for any answer.

grub 04-07-2003 12:53 AM

Can you post the sequence, and where it hangs
i.e, the exact error message displayed or the kernel hanged after displaying some message.

ANewbie 04-07-2003 09:26 AM

There is no error message.
After Lilo has selected linux to be the operating system to boot
it says something like:
Uncompressing linux
Ok, booting the kernel.
After that nothing happens... I let some minutes pass and then I turn the computer off.

jpbarto 04-07-2003 04:41 PM

could be the installed kernel doesn't have support for some kind of hardware...
could it be possible to boot from the floppy, copy the kernel image from the floppy to the hard drive, edit lilo.conf to include the new floppy kernel, run lilo, reboot and try to boot the machine off the new kernel image?

ANewbie 04-08-2003 10:50 AM

I have looked at lilo.conf, and almost understood it. What file should i copy where, and with what command? And which lines should I put in lilo.conf?

jpbarto 04-08-2003 11:47 AM

is there a file named bzImage (or vmlinuz) on the floppy disk? this is the kernel... then in lilo.conf copy four lines...

should look something like this:
image = /boot/bzImage
root = /dev/hda1
label = linux
read-only

there will be some lines already like this in your lilo.conf... copy / paste these four lines to add a new kernel...

something like this:
image = /boot/floppy-img
root = /dev/hda1
label = floppy_linux
read-only

then when you are done editing lilo.conf save it and at a command prompt execute 'lilo' to rewrite the boot table...

that should do it... now when you start your computer when lilo starts up you should be able to select floppy_linux to boot from (without using the floppy disk).

ANewbie 04-08-2003 11:59 AM

I figured out how to do it with the config-program KDE provides, and it seems to work!

Thanks for your help!
/A satisfied newbie

wouters_frederik 12-07-2005 02:00 AM

booting the kernel *hang*
 
Hello,

I (succesfully) used (dualboot win +) Suse linux until recently and wanted to switch to (dualboot win +) ubuntu.
ik have a seperate drive on which my suselinux is installed.
If try a ubuntu live cd or install cd I get the exact same hang
-uncompressing linux Ok. Booting the kernel *hang*
how come suse and red hat runned on my system and this ubuntu doesn't???
I have a AMD 2200+ with 1Gb ram and 2 discs (120 Gb(data + win) & 20Gb (OS)

I don't understand what is the problem, didn't find many info on the web..
I would like to introduce my family to this linux (already got the cd's)
but can't get the bloody thing to work on my own pc.

-also tried knoppix / beatrix / slax
they hang too before loading the kernel

Does anybody recon this problem and know how to solve it??

I hope so

thanx in advance!!


All times are GMT -5. The time now is 10:13 PM.