LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Booting stops after: Unable to access resume device, mount: could not mount ... (https://www.linuxquestions.org/questions/linux-newbie-8/booting-stops-after-unable-to-access-resume-device-mount-could-not-mount-717112/)

lespaul047 04-06-2009 03:52 AM

Booting stops after: Unable to access resume device, mount: could not mount ...
 
After updating kernel 2.6.27.19 to 2.6.27.21 my computer stops booting after the message:
Unable to access resume device
Mount: could not mount filesystem (/dev/root)
With grub I'm able to boot the previous version and I notice some changes:
1. My 'good' configuration boots from root=/dev/VolGroup00/LogVol00 (I kept the default lvm-names) and my 'bad' config boots from root=/dev/dm-0.
2. When I type mount in terminal after booting the 'good' config I see the mount points are indeed /dev/dm-0 and so on. In LVM-manager I can't see them, because I see the 'old' names (LogVol and so on). Where is the mapping? LVM manager says the LogVols are not mounted...

Can anybody explain this to me? For what I see, my disk is devided in LVMs with the access /dev/VolGroupXX/LogVolXX and somehow there is an extra entry with names like /dev/dm-X.

Then, I rescued: chroot blabla and I tried to mkinitrd and so on. I also swapon, mkswap and swapoff, but no progress. The only change was that /dev/root not found changed in /dev/dm-3 (propably my swap partition)...
I also mkinitrd with scsi_wait_scan, but no result.

Anybody?

janhe 04-06-2009 08:08 AM

You need to configure grub so that it can mount your root (the one that is mounted on /) partition.
Since you already tried to build a new initrd, I assume the configuration is pointing to the wrong root device.
Try changing the root=option to the same as your "good" configuration.

If that doesn't help, you maybe have a problem with the kernel modules (the right modules isn't provided, it isn't in the initrd, or something else driver-related)

lespaul047 04-06-2009 05:50 PM

I did what you suggested, but the problem remains. Although, now it is the swap space which cannot be found. It is in my lvm-config, but there is no mount point (/dev/dm-3) in the fstab file. Then, I found out there is a program (running somewhere, doing magical stuff??) called dmsetup. I tried to find out WHAT that program does, but the only thing I read is that it is a low level device mapper and I can see a lot of commands.


All times are GMT -5. The time now is 03:59 AM.