LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-24-2003, 04:04 AM   #1
talkinggoat
Member
 
Registered: Sep 2003
Location: lafayette, la
Distribution: RHL 6.2, FC 3, Ubuntu 14.04, Ubuntu 16.04
Posts: 112

Rep: Reputation: 15
booting resolution


when i boot linux, the resolution is too high for the monitor that it is currently on. it was installed on a monitor that could support high res... how do i get it to boot into a text shell to make the necessary mods with x configurator? i don't seem to see anyplace to do this. what do i do?
 
Old 09-24-2003, 05:55 AM   #2
ceedeedoos
Member
 
Registered: Aug 2003
Location: Antwerp, Belgium
Distribution: Slackware 10.0, Mandrake 10.1
Posts: 174

Rep: Reputation: 35
su
vi /etc/inittab
exit

in inittab change the "x" in #id:X:initdefault:

if you set X to 3 you will boot to the command line
if you set X to 5 you will boot into a GUI

I think that should work
 
Old 09-24-2003, 06:10 AM   #3
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 4,065

Rep: Reputation: Disabled
Depends on your boot-loader (LILO / GRUB ?) -- assuming you can't briefly borrow a better Monitor. The boot-loader should allow an option to force a low resolution (600 * 800). So man <boot-loader> . You can carry on from there, I believe.
 
Old 09-25-2003, 02:15 AM   #4
talkinggoat
Member
 
Registered: Sep 2003
Location: lafayette, la
Distribution: RHL 6.2, FC 3, Ubuntu 14.04, Ubuntu 16.04
Posts: 112

Original Poster
Rep: Reputation: 15
ok, i fixed the problem. not sure if it was the best way to do it, but it worked... i pressed ctrl+alt+bkspace until it got to the text only screen with the prompt "%hostname% login:" i logged in and ran Xconfigurator. this fixed the prob. i don't know if that was the right way to do it, though. there has to be a better way...

ceedeedoos

i know that would fix the problem of it going into the xterm login... and it would allow you to run Xconfigurator, but i could not get to a point to edit that file. the moment x would start, the monitor would turn off. you are right, though. that would work to boot me into a safe text only mode.

JZL240I-U

i'm using grub. don't know if that would work or not... do i do that while still in the boot loader (use the extra commands that it provieds) or do i do that at a prompt? that sounds like you are on the right track, though.

cee, jzl, thanks for the help, guys.
 
Old 09-25-2003, 02:32 AM   #5
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 42.1_64+Tumbleweed-KDE, Mint 17.3
Posts: 4,065

Rep: Reputation: Disabled
Just a personal comment: If it works, it is the right way . There may be better ways or optimizations to what you did, but for the moment it doesn't matter, because you solved a problem and made your system work -- and quite efficiently, at my opinion.

And it will keep your brain on alert (in this area at least ) when you see something concerning the boot sequence or GRUB commands ... so, all is well .

[edited] Oh, yes, you would do that with the commands GRUB provides before it starts loading everything.

Last edited by JZL240I-U; 09-25-2003 at 02:34 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing Knoppix Screen Resolution Prior to Booting dudeman41465 Linux - Software 1 09-24-2005 01:17 AM
Resolution when booting up Riddick Slackware 1 09-18-2005 10:27 PM
X: using larger resolution for games than default desktop resolution Jamo Linux - Games 2 04-10-2005 04:16 AM
Text Resolution, Graphic resolution. Change from prompt dlublink SUSE / openSUSE 2 01-28-2005 12:50 PM
High resolution on booting spank Linux - Newbie 4 08-26-2003 04:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration