-   Linux - Newbie (
-   -   booting mess! (

zeppelin 09-02-2003 11:06 AM

booting mess!
hello. I have 2 questions to make:

a. How can I tell to the kernel to forget a device (everytime I boot i tries to installs it, and fails and gives warning and so on..)

b. I have to execute (while booting) this command:

echo -ne "\033(K\033)K" > /dev/tty

I have it in rc.font
rc.font is executable and runs while booting, yet I get an error about the /dev/tty..

I wanna have this echo on all tty..

help is needed, thanks in advance:study:

nhs 09-02-2003 02:18 PM

As to your first question, I don't know enough to pinpoint the problem. What is the output from dmesg?

Your second problem is easier to answer. Change echo -ne "\033(K\033)K" >/dev/tty to:

for tty in /dev/tty[0-9]*;
do echo -ne "\033(K\033)K" >$tty;

This will output to every tty on your computer.

zeppelin 09-03-2003 09:29 AM

hey that worked! thanks nhs.. ;)

yet the kernel still tries.. and tries.. (and again and again...)

nhs 09-05-2003 03:14 PM

Which device does it try to install? What is the output from running dmesg? Is it definately the kernel or is it kudzu?

zeppelin 09-05-2003 05:24 PM

i mont really sure about kudzu.. (i have slackware haven't seen since i moved from redhat)

anyway, there is a PCI card (radiolink fm audio)
and tries insmod but fails..

the thing is I want the kernel to forget it for EVER!

nhs 09-07-2003 01:21 PM

I have no never used slackware however if you want a definate solution, try renaming the module file (somewhere in /lib/modules/`uname -r`/drivers/) to some other name or moving it into your home directory (or anywhere that insmod won't find it). This should change the error to a module not found error, but this should start up quicker.

zeppelin 09-08-2003 10:14 AM

ok. but that won't fix me. Not anyone knows how to do this simple disable thing..

anyway thank you

All times are GMT -5. The time now is 12:12 PM.