LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Booting Fedora 12 from Ubuntu's Grub2, ERROR: NOT AN ASSIGNEMENT (https://www.linuxquestions.org/questions/linux-newbie-8/booting-fedora-12-from-ubuntus-grub2-error-not-an-assignement-786568/)

mitchell7man 02-02-2010 10:23 PM

Booting Fedora 12 from Ubuntu's Grub2, ERROR: NOT AN ASSIGNEMENT
 
Okay, so I'm trying to boot my Fedora 12 partition, but am failing miserably, when I try to boot Fedora 12 I get "ERROR: NOT AN ASSIGNMENT"

my 40_custom file is as follows:
Code:

#!/bin/sh
exec tail -n +3 $0
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.

menuentry "Fedora (2.6.31.5-127.fc12.x86_64)"
{
  set root = (hd0,2)
  linux /boot/vmlinuz-2.6.31.5-127.fc12.x86_64 ro root=UUID=9990b87d-e7e1-4859-be4c-2885b8e6eb46  LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet
    initrd /boot/initramfs-2.6.31.5-127.fc12.x86_64.img
}
#menuentry "Fedora 12"
#{
#set root = (hd0,3)
#linux /boot/vmlinuz-2.6.31.1-127.fc12.x86_64 root=/dev/sda3 ro quiet splash
#initrd /boot/initramfs-2.6.31.1-127.fc12.x86_64.img
#}

Note that I tried this using the entry that is currently commented out and I had the same result. Does anyone know what is wrong? The entry that is currently uncommented came directly from the grub entry created by fedora itself (before I installed ubuntu).

Thanks in advance,
MJ

slacker_et 02-03-2010 03:19 PM

Does Grub2 allow ( and ) in menu entries ?

--ET

mitchell7man 02-03-2010 11:56 PM

I don't get what your saying...

linuxlover.chaitanya 02-04-2010 12:09 AM

Why dont you try your fedora entries by removing the parenthesis from the entry name?

Phoxis 02-04-2010 02:17 AM

Similar post: http://www.linuxquestions.org/questi...gnment-751076/
grub.cfg : http://grub.enbug.org/grub.cfg


All times are GMT -5. The time now is 04:05 AM.