-   Linux - Newbie (
-   -   Booting: Device 0x0309 exceeds 1024 cylinder (

Freeek 09-27-2003 10:36 AM

Booting: Device 0x0309 exceeds 1024 cylinder
I installed RHL 8.0 on my friend's PC, and it's not booting without a bootdisk. So to fix it, I booted with the bootdisk, logged in as root, and tried the lilo command at the terminal. It gave the following error:
Warning - Device 0x0309 exceeds 1024 cylinder limit
Fatal : Sector 77516620 - Too large for Linear mode (Try lba32 instead)

He has a P4 1.7 GHz PC with an Intel 845 motherboard and a 40GB HDD, and linux is installed on an extended partition, at around 32 GB. The extended partition has a 100 MB /boot partition, a 256 MB swap partition and the main partition in the rest of the space. Lilo was installed on the /boot partition

The same configuration on my 20GB HDD works fine, with Linux installed on last 3 GB of the HDD, and works perfectly fine!

I read somewhere that the above problem could be caused if the linux partition is beyond 8GB, but in that case, it shouldn't have worked on my PC also!

I want to know how I can fix this problem without having to reinstall Linux! Please help!!!! I'm quite sure that the LBA setting is enabled in his BIOS.

Mara 09-27-2003 12:46 PM

The 1024 cylinder is not a problem here, it's just a warning (and it's not important, LILO in RH 8.0 can boot from above).
The problem is in the /etc/lilo.conf file. Somewhere inside there's an line with 'linear'. Change it to 'LBA32'. If there's no 'linear' line, make sure the disk mode in BIOS is set to LBA.

All times are GMT -5. The time now is 03:49 AM.