LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Boot Up Problem - Cannot Login (https://www.linuxquestions.org/questions/linux-newbie-8/boot-up-problem-cannot-login-49038/)

benny 03-09-2003 09:51 PM

Boot Up Problem - Cannot Login
 
:Pengy:
I have just upgraded to RedHat7.2 from RedHat6.1. At the first time I started, the XWindow GUI prompted me for login. After providing the Username/Password, it tried to load the desktop, but failed. It returned to the logon screen. I guessed that it could be related to the display resolution.

Then, I booted as single mode and get into the shell. Then, I ran Xconfigurator and restored the display parameters that I used to be. Finally, I configured the Xwindow such that I don't want it to be started automatically.

Then, I booted again and get a shell. After providing the Username and pressing ENTER, it prompted the Login prompt without asking my password.

Can anyone help me to get thru' this "repeating Login" and why it did not ask me for Password? Thanks a lot.

JStew 03-10-2003 07:24 AM

check /var/log/messages to see if you are indeed not being validated

benny 03-10-2003 11:06 AM

Having checked "/var/log/messages", it is empty and its timestamp is 6-Mar-2003 (before my upgrade).
BTW, I am not sure whether it is related to PAM or /etc/shadow. I can only get into the shell by booting as "linux single" mode. I tired to follow the tips suggested by "Bootdisk-HOWTO/buildroot.html section 4.4.1". However, I failed to run "ldd /bin/login", it said I don't have permission for doing so. How to tackle this?

Anyway, I have done the followings:
(1) Created "/etc/pam.conf", "/etc/pam.d/passwd", "/etc/pam.d/login" and copied these 3 files to the root filesystem.
(2) Copied /lib/security/pam_permit.so to the root filesystem.
(3) Copied /lib/libpam.so to the bootdisk.

Then, I booted as normal, it did not improved any (the Login: prompt showed all the time)
Please help...

JStew 03-10-2003 05:24 PM

you've been using 6.1 and are just now upgrading to 7.2? im sure that could have caused a lot of problems


All times are GMT -5. The time now is 06:08 AM.