-   Linux - Newbie (
-   -   boot time problem (

enderel 04-04-2003 04:51 AM

boot time problem
i just managed to make my slack boot up with vesa framebuffer, the problem is that no matter what VGA option i put in lilo.conf, it goes to 640x480
however, X works with a 1280x1024x24 resolution
what can i do to make it work?

iceman47 04-04-2003 04:13 PM

this may sound stupid, but did you run /sbin/lilo after editing lilo.conf?

enderel 04-05-2003 12:07 AM

i did run lilo after modifying the .conf file, it's not that and i think it's not my video card either as it works in X and as i recall it worked at boot time before i recompiled the kernel
but thanks for your trouble

iceman47 04-05-2003 07:06 AM

Modify the line vga= in /etc/lilo.conf to vga=ask, run /sbin/lilo again then reboot.
When lilo starts up it'll ask for a resolution, try if either of these:

| 640x480 800x600 1024x768 1280x1024
256 | 769 771 773 775
32K | 784 787 790 793
64K | 785 788 791 794
16M| 786 789 792 795

or in hex=

| 640x480 800x600 1024x768 1280x1024
256 | 0x301 0x303 0x305 0x307
32k | 0x310 0x313 0x316 0x319
64k | 0x311 0x314 0x317 0x31A
16M| 0x312 0x315 0x318 0x31B

also, make sure you've compiled vesa framebuffer support for your videocard in the kernel
when the ask method works, replace the vga=ask line with the res you want. (mine is vga=0x305).

enderel 04-06-2003 10:17 AM

the thing still doesn't work, no matter what value i give to lilo it goes into 640x480
what bothers me is that it used to work with the first kernel i had, but i had to change that one and i erased it
isn't there another kernel config option that affects this, besides VESA Framebuffer?
thanks for you trouble

iceman47 04-06-2003 01:34 PM

well I have framebuffer, nvidia riva support and VESA VGA graphics console enabled

All times are GMT -5. The time now is 02:25 PM.