LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-26-2006, 06:10 PM   #1
Falconer
LQ Newbie
 
Registered: May 2006
Posts: 2

Rep: Reputation: 0
Question Boot (pre-installation) crash on HDA detection


Booting goes normally until it comes to :

hda: attached ide-disk driver.
hda: host protected area => 1

and than it crashes . i tried all kernels .. even those not neccecary (OS is Slackware 10.1 )

is there any solutions for this , and if not , is there a way that i install it directly from hdd (to edit boot sector manually , and then to copy iso and boot files to ext2 partition (including installation files ) and than to run it from hdd ) ?

thanks

 
Old 05-26-2006, 06:17 PM   #2
lotusjps46
Member
 
Registered: Apr 2003
Location: Dallas
Distribution: Vector Linux, Suse 10.1
Posts: 186

Rep: Reputation: 30
How do you have your hard disk partitioned? Is there a suitable partition to install Linux to? Did you check the iso file you made the disk from, and verify the CD after you burned it?

If you really want to do a hard-drive install, this works:

ftp://ibiblio.org/pub/linux/distribu....html#harddisk

That gets you Vector Linux 4.3, which is old but real good for older machines. Give us some more information and maybe we can help you out.

Good luck

C
 
Old 05-27-2006, 10:38 AM   #3
khaleel5000
Member
 
Registered: Oct 2005
Location: Pakistan
Distribution: Debian,Pclinuxos
Posts: 327

Rep: Reputation: 31
tell me the name of motherboard , when i tried to boot i redhat linux 7.3 or 8.0 (cant remember) on my new p4 it showed my cdrom when booting but later asked for selection of install source! although i had used same cd to install the OS on my p3
later i came to know that new boards had come BIOS option to be changed
 
Old 05-27-2006, 11:36 AM   #4
Falconer
LQ Newbie
 
Registered: May 2006
Posts: 2

Original Poster
Rep: Reputation: 0
I have one fat32 partition with winXP on it , one ext2 partition (size approx: 15gb ) , and one linux swap part. with 512mb . i have knoppix (cd boot compact linux) and it boots without any problems , and it can detect and read/write on hdd normally .

my pc config :

MB asus P4P800 vm
CPU : intel celeron 2.2 ghz
Memory : kingston 256 mb ram 333mhz
HDD : maxtor ide-ata 40gb
GP : asus graphics with nvidia GF4 mx 440 (64mb memory ) agp 8x
2 cd drives (one asus cd-rw , one asus dvd-rom)
other stuff is standard (integrated or irrelevant pci - tv tuner card ... etc .. )
Modem intel 56k (winmodem)

i have some bad sectors on HDD maybe that is a problem ?

@offtopic if someone knows some free good win32 software for bad sectors removal (but one that actually does it ) i would appreciate some links .

thanks
 
Old 05-27-2006, 12:31 PM   #5
lotusjps46
Member
 
Registered: Apr 2003
Location: Dallas
Distribution: Vector Linux, Suse 10.1
Posts: 186

Rep: Reputation: 30
Did you burn this disk yourself, or did you buy it? Oddly, I have had two bad discs that came in packaged Linux distributions, and one was Slackware 10.1. Nothing would get it to intall. Also, some CDROM's have trouble reading some media. Can you try burning a new CD using a different brand of media?

Good luck.

C
 
Old 05-28-2006, 04:15 AM   #6
khaleel5000
Member
 
Registered: Oct 2005
Location: Pakistan
Distribution: Debian,Pclinuxos
Posts: 327

Rep: Reputation: 31
I googled it and found no complains for this board and slackware 10.1 (as far as I saw) try other distro , or other burned disk as lotusjsp46 suggested.
Might be that the harddisk is very screwed up and so the disk cant be accessed or something
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vaio sz1m/b - pcmcia detection crash mane.x Linux - Laptop and Netbook 1 05-25-2006 07:01 AM
Some pre-installation questions harrylmh Slackware - Installation 4 11-08-2005 02:34 AM
Pre-Installation set-up !!! (Oracle 9i DB) ptreves Linux - Newbie 17 08-16-2004 04:26 PM
pre- installation inq Robin01 Linux - Newbie 1 10-10-2003 02:07 PM
Pre-installation Problems Config Slackware 4 07-04-2002 08:04 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration