LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-24-2006, 06:53 AM   #1
ubuntuuser
LQ Newbie
 
Registered: Jan 2006
Distribution: Ubuntu 5.10
Posts: 11

Rep: Reputation: 0
Boot Options


Is there any way to change which os boots up in the GRUB bootloader?
I am currently running ubuntu 5.10 and I wish to make window$ xp boot first.
Any help would be appreciated.
 
Old 02-24-2006, 07:04 AM   #2
aus9
LQ Addict
 
Registered: Oct 2003
Location: Australia
Distribution: MX 16
Posts: 5,283

Rep: Reputation: Disabled
have a read of my tut or look for the line in your /boot/grub/menu.lst and counting from zero change the DEFAULT number to your preference
 
Old 02-24-2006, 07:09 AM   #3
Ipsofacto
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 132

Rep: Reputation: 15
You need to change the /boot/grub/menu.lst file.

In that file will be a "default = <x>" - where x is a number. The number zero will mean it will boot the first entry, number one will mean it will boot the second.

Assuming that windows is your second entry and ubuntu is your first, then you need to change the default to 1 (as opposed to 0).

Are you familiar with editing these types of files using a text editor ?

EDIT - someone can obviously type faster than me!!!
 
Old 02-24-2006, 01:29 PM   #4
BinJajer
Member
 
Registered: Sep 2005
Location: Warsaw, Poland
Distribution: Slackware 10.2, Caldera OpenLinux 3.1, Corel Linux (Thanks xhi!), Debian GNU/HURD etc...
Posts: 296
Blog Entries: 1

Rep: Reputation: 30
[RULE_VIOLATION] Please, post this sticky, any of you mods![/RULE_VIOLATION]
Oh, and you can use the savedefault option. Refer to the grub's man.
 
Old 02-24-2006, 01:59 PM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Quote:
Originally Posted by BinJajer
[RULE_VIOLATION] Please, post this sticky, any of you mods![/RULE_VIOLATION]
What on earth are you talking about???
 
Old 02-24-2006, 06:47 PM   #6
Ipsofacto
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 132

Rep: Reputation: 15
Had I taken copious amounts of acid, I couldn't of agreed more. Hahahaha!!!

Last edited by Ipsofacto; 02-24-2006 at 10:27 PM.
 
Old 02-24-2006, 10:17 PM   #7
ubuntuuser
LQ Newbie
 
Registered: Jan 2006
Distribution: Ubuntu 5.10
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Ipsofacto
You need to change the /boot/grub/menu.lst file.

In that file will be a "default = <x>" - where x is a number. The number zero will mean it will boot the first entry, number one will mean it will boot the second.

Assuming that windows is your second entry and ubuntu is your first, then you need to change the default to 1 (as opposed to 0).

Are you familiar with editing these types of files using a text editor ?

EDIT - someone can obviously type faster than me!!!
No, I'm not very familiar with the text editor. I tried editing that file once but it was read only (or whatever) and it wouldn't let me change anything.
 
Old 02-24-2006, 10:38 PM   #8
Ipsofacto
Member
 
Registered: Sep 2005
Distribution: Debian
Posts: 132

Rep: Reputation: 15
Ok, i'm not sure what editor comes with Ubuntu but you should try (as root) either:

pico /boot/grub/menu.lst

(or)

nano -w /boot/grub/menu.lst

Use the cursor keys and scroll down to "default" and providing Windows is your second entry change the entry to "default 1".

Then push <control> O to save (O equalling the letter, not the number), and then enter. Then reboot. You *should* be good to go.
 
Old 02-25-2006, 10:19 AM   #9
ubuntuuser
LQ Newbie
 
Registered: Jan 2006
Distribution: Ubuntu 5.10
Posts: 11

Original Poster
Rep: Reputation: 0
I got it! This is what I did:
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
savedefault
default 5

You must add "savedefault" for it to use the default number. Thanks for all your help!
 
Old 02-26-2006, 02:00 AM   #10
aus9
LQ Addict
 
Registered: Oct 2003
Location: Australia
Distribution: MX 16
Posts: 5,283

Rep: Reputation: Disabled
actually I disagree...if it works for you good but its actual function (savedefault) is for those people who do not like to edit their menu and want the last booted operating system made the default to the next boot

http://www.gnu.org/software/grub/man...vedefault.html

(2) if you deleted the savedefault line and only had the default line....eg
default 2....

then the third title down is what is booted unless you press the arrow keys or escape key at the menu stage
 
Old 02-27-2006, 05:54 PM   #11
ubuntuuser
LQ Newbie
 
Registered: Jan 2006
Distribution: Ubuntu 5.10
Posts: 11

Original Poster
Rep: Reputation: 0
Whatever. That's what I did and it works fine for me.
 
Old 02-27-2006, 06:05 PM   #12
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
Just so you know in the future how to edit read only files in Ubuntu, from a command line type sudo gedit /path/to/filename where the /path/to/filename is the correct path. That will let you edit as root user using the gui gedit program. If you want to use an simple command line type editor, just change gedit to nano...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless Keyboard not working to select boot options (Grub boot loader) psrini_vasan Fedora 7 12-16-2009 05:45 PM
Grub boot loader menu shows two linux boot options pramos Linux - Newbie 3 09-12-2004 11:40 PM
What are these two boot options? deanbrown3d Linux - Newbie 6 08-20-2004 09:08 AM
boot options delos Linux - Networking 0 07-10-2004 02:23 AM
Options during boot? sikandar Linux - Software 15 01-10-2004 11:28 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration