Latest LQ Deal: Latest LQ Deals
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 02-03-2010, 06:03 AM   #1
LQ Newbie
Registered: Oct 2006
Posts: 26

Rep: Reputation: 16
boot fails with "grub _" flashing on monitor

Hi. Can someone help me with a grub problem?

I replaced the battery on the mother board and now I can only boot with a knoppix livecd!

When I try to boot normally, the system goes through the POST but instead of the grub splash screen, it displays the word "grub _" followed by an underscore.

Background: Very stable, Pentium 3, linux (2.6.8-1) All the linux installation files are on a separate harddisk - hda. It has a software raid raid1(md0) consisting of 2 mirrored scsi hard drives (sda1 and sdb1).

More background: Last week I had a "kernel panic loop 1" message and a bunch of icmpv6 errors which locked up the system console and all the pc's that used the samba share. I managed to quell the icmp problem by restarting networking services. Not sure what kernel panic means. I thought maybe it was related to the icmp errors. It worked another week until I lost a samba share again. Restarted samba and the console locked. Had to ssh into the pc to shutdown / restart. On restart, pc says that md0 has a bad superblock and hangs waiting for me to do something with the superblocks. I don't know how to run e2fsck thought I'd just try at minimum to get the pc up since it handles samba for the network. I wanted to fix the raid later...when I have time to research it.

So... I went into fstab and changed columes 5 & 6 of md0 from 1 2 to 0 0 respectively. I did this so as to get around the superblock message. That notion worked and was able to restore all the services.

I have to power off in order to move the pc back into production and thought I'd take the opportunity to vacuum and reseated all the cables, memory sticks. After that boot goes directly to the bios - the system says that my motherboard cpu clock and the bus frequency don't match. I'm wondering why these settings are being reported as a problem - they haven't changed. I hoped it is something simple so I replaced the battery and things go from bad to worse.

Now pc doesn't even get to the grub splash screen it just sits there blinking "grub _" .

I used knoppix to confirm that the boot directory is still intact and the grub.conf is there too.

Old 02-03-2010, 08:50 AM   #2
Senior Member
Registered: Oct 2003
Posts: 2,977

Rep: Reputation: 386Reputation: 386Reputation: 386Reputation: 386
The grub problem is probably caused by your bios setting reverting to default when you removed the battery and replaced it with a new one. Check the boot order priority in your bios setup and try putting your hda hard drive first in the boot order. That assumes that assumes that your kernel and initrd lines in grub.conf are listing (hd0,*) with the "*" being the partition where root resides. Grub enumerates hard drives based upon their boot order priority in the bios setup. The first listed hard drive is given the hd0 designation. If hda got moved in the hard drive boot priority in the bios setup upon the bios resetting to default, it could result in the type of grub error you are experiencing.
1 members found this post helpful.
Old 02-03-2010, 11:23 AM   #3
LQ Newbie
Registered: Oct 2006
Posts: 26

Original Poster
Rep: Reputation: 16
Thank you. It was not the boot order but it was the bios. After you said that I found western digital hard drive installation guide and the mother board instructions. The wd guide said I should disable LBA and manually enter the values. The mother board said I should specify "use existing partitions" if I was reinstalled existing hd with os. Both those options, together or separately failed. I finally used autodetect and lba together. This caused the the bios to report that I have 255 heads. Weird becasue WD install guide I have 16 heads. Maybe the guide is wrong. or maybe I have the wrong guide. I will pull the hd out later to confirm the heads. In the meantime - all is well in the neighborhood with the exception of the badsuperblock on md0. I'll fix that this weekend. Thanks again for pointing me in the right direction.
Old 02-03-2010, 01:25 PM   #4
LQ 5k Club
Registered: May 2003
Location: London, UK
Distribution: Fedora38
Posts: 6,147

Rep: Reputation: 435Reputation: 435Reputation: 435Reputation: 435Reputation: 435
I finally used autodetect and lba together. This caused the the bios to report that I have 255 heads. Weird becasue WD install guide I have 16 heads.
LBA is "Logical Block Addressing". That is what you want. Do not pull your HDD, there's no need. The BIOS translates the "255 heads" to the 16 real ones. The OS does not care.

Cylinder, Head, Sector addressing is sooooooo .... 1980's:


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] There is no "menu.lst" in my Ubuntu "/boot/grub/" folder. msbstar Linux - Newbie 18 09-15-2012 02:26 PM
grub boot to "1" "S" or "single" chakkerz Linux - Newbie 2 12-09-2009 01:35 AM
grub 0.97 on sda2 (NTFS) fails silently on "Loading stage2" arielCo Linux - General 3 04-29-2009 08:24 AM
uninstall boot loader "Lilo" install "Grub" sethis Linux - Newbie 6 11-30-2006 10:32 AM
grub list "MZ" for my windows boot "Help on Change" davimint Linux - Newbie 2 01-26-2006 07:22 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:35 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration