-   Linux - Newbie (
-   -   Boot error when trying to boot from USB (

sumeet inani 02-01-2010 06:54 AM

Boot error when trying to boot from USB
I am using ubuntu 8.04.
I used unetbootin to create bootable USB disk using iso of ubuntu-8.04
It booted a system of my friend(his CPU is different than mine) but not mine.
Only message that comes is 'Boot error'.A few months ago it booted USB without a hitch.
What do you suggest should be my BIOS configuration ?
Have you encountered this .
My system is 3GHz Core2Duo,2GB DDR2 RAM.
I also think that this is hardware problem not directly to linux.Still somebody who faced something similiar can guide me or whose USB boot is perfect can say what options should be set.

Currently my BIOS setting is

boot to removable devices:enable
USB boot:enable
boot USB devices first:enable

amani 02-01-2010 12:35 PM

some h/w problem apparently. check with some other image

Does your smps provide enough power?

out put of dmesg (relevant parts)

jefro 02-01-2010 10:03 PM

Be sure to turn the system off to a full power down. Then maybe use bios to select the boot deviceinstead of using boot screen F key to select. What I mean is some bios's show the usb device as a hard drive instead of a usb device. I have to move up in order the hard drive to allow my flash drive to boot.

When I see that error it means I had a bootable drive but later deleted syslinux or an important file(s).

worm5252 02-01-2010 11:31 PM

Have you tried booting from the USB drive on another machine since you have received the boot error? Have your tried booting another bootable usb drive on the system in question? Have you tried running fsck or e2fsck on the USB drive to fix any issues?

sumeet inani 02-02-2010 08:57 AM

To jefro
I plugged USB first then turned on system & went into BIOS to set hard drive order as
TSVJF(i think my pendrive's model)
because I have just one hard drive of 300GB
but same message 'boot error'
I found syslinux.cfg in USB.More explanation

$ find /pd -iname '*lin*'

Anything else expected.

to amani
you said related to smps.
i can just say that during bootup the LED of my pendrive glows and system has no UPS just direct connection to AC current.
Do you mean that I boot from hard drive & see output of dmesg.
If I do that let's say plug USB first then power the system.I get 'boot error' then press enter to get grub menu for my hard drive & get into ubuntu.

$dmesg | grep -i error
[  39.831772] ACPI: Looking for DSDT in initramfs... error, file /DSDT.aml not found.

Now what?

to worm5252

root@lxuser-desktop:~# dosfsck -a /dev/sdb1
dosfsck 2.11, 12 Mar 2005, FAT32, LFN
/dev/sdb1: 232 files, 22818/62493 clusters

What do you say?

Since you said to try same USB again on a different computer.I did ( on dual core 2GB RAM,2.5GHz ) & it worked so I can conclude that there is a fault in my CPU.
The same USB did not work on another CPU of a friend of same model (i.e. core2duo 2GB RAM , 3GHz ).
What do you say ? Does core2duo stop booting from USB after few months.

NeilR 02-18-2010 02:30 AM

I had this same problem and it turned out to be down to formatting of USB.

My machine BIOS will not boot from a HDD formatted stick - i.e with a primary partition like /dev/sdc1 on the device.
I had to make sure it was in "superfloppy" format. In Linux you can use the command "mkdosfs -v -I /dev/sdc" (if your USB is on /dev/sdc) to create the right format.
Take care how you create the boot USB - Ubuntu will always format the stick as HDD-type! I used to create mine but perhaps you can look around for some other methods that don't involve Windows!


sumeet inani 02-22-2010 01:25 AM

Software from pendrivelinux for ubuntu 8.04 iso worked well.
In GNU-Linux I did
#mkdosfs -v -I /dev/sdb
This deleted all partition on USB as indicated by unallocated /dev/sdb in gparted GUI but strangely I can mount /dev/sdb manually ( using vfat type ) & copy files to it though gparted still says unallocated .
In windows USB drive work well as FAT32.

I read man page of mkdosfs which says

-v means verbose execution
-I file system to whole disk or super-floppy format as you said

now using unetbootin as earlier in ubuntu 8.04 I get bootable USB.

My pendrive became empty after
#mkdosfs -v -I /dev/sdb

ryzahlic 01-09-2013 10:32 AM

same thing happened to me also, I can not install Linux Ubuntu 12.04 LTS in my desktop computer (FX-4100 3.7 GHz, 2 GB RAM) thou I already make bootable Flashdisk with unetbootin, it worked before for my Laptop (Intel Core2Duo 2.4 Ghz, 1 GB RAM)
first I thought it was because Processor difference

All times are GMT -5. The time now is 07:13 AM.