LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Bluetooth Earphones wont work (https://www.linuxquestions.org/questions/linux-newbie-8/bluetooth-earphones-wont-work-4175527096/)

tarbetb 12-02-2014 09:53 AM

Bluetooth Earphones wont work
 
I am new to Linux and have installed Ubuntu 14.04.1 LTS on an older laptop. I purchased an iomega bluetooth USB adapter that one of the reviewers had gotten to work on his Linux system. The Adapter is installed and seems to work. I have 2 different Bluetooth stereo headsets I am trying to use with the adapter. I can click the bluetooth icon in the lower right and scan and link to either headset. They are listed in the bluetooth manager correctly. I can rigth-click and choose "Headset Service" and the indicator in the bottom of the manager says "Success" after a few seconds of trying to link. But no audio is heard from any source in the PC. I right-click and choose Audio Sink and I hear a beep in the headsets, but get the message "Connection Failed:Stream Setup Failed" in the lower left corner of the bluetooth manager. Any ideas of what to try.
Thanks

yooy 12-03-2014 02:57 AM

Seems to me like a bug, maybe it is worth upgrading to 14.10 that is currently the latest version?


------------------------------
Which Bluetooth Stereo Headset?

Soadyheid 12-03-2014 05:26 AM

Are you able to select the earphones as the output device in the Audio setup utility? Looks like you've already set up the bluetooth.

Play Bonny!

:hattip:

tarbetb 12-03-2014 03:33 PM

Problem solved
 
After reading other Linux blogs, I found that this is a bug in Linux 13 and 14.10. I found a solution that worked - it has to do with the bluetooth manager not linking with pulsaudio correctly. The solution I found was on the Linuxliteos forum (linuxliteos.com). Here is a paste from that solution
THe problem is desribed in more detail at

https://bugs.launchpad.net/ubuntu/+s...o/+bug/1181106 - post 15
https://bugs.launchpad.net/ubuntu/+s...o/+bug/1283003 - post 92

For the curious, the second link will explain to you why this fix is necessary in more
detail.


Solving this problem involves:
1. Adding a PPA, and
2. Updating blueman (the Bluetooth manager) and installing the modules that
interface Bluetooth with pulseaudio.

First, add the PPA:
Open a terminal window [CTRL-ALT-T] and enter the following:
Code: "sudo add-apt-repository ppa:cschramm/blueman"

Enter the sudo password, and you should see this:

More info: https://launchpad.net/~cschramm/+archive/blueman

Press [ENTER] to continue or ctrl-c to cancel adding it
Press enter to add the PPA. After the PPA is added, enter the following text:

Code: "sudo apt-get update && sudo apt-get install blueman pulseaudio-module-bluetooth"

If you get any messages (you shouldn't) saying these are already installed, they can
be ignored.

Lastly, reboot into Linux Lite. The Bluetooth manager will now allow Audio Sink
(A2DP) to be enabled.
This fix works not only on Linux Lite, but on ANY Ubuntu 14.04-based distro that uses
pulseaudio - most, if not all of them, share this same issue...


All times are GMT -5. The time now is 10:56 AM.