LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   blank virtual console? (https://www.linuxquestions.org/questions/linux-newbie-8/blank-virtual-console-124652/)

yanar99 12-10-2003 03:05 PM

blank virtual console?
 
hello there.

i just newly installed red hat 9.0, dual-booting with winxp. xp and the linux desktop work fine.

however, when i try to do a Ctrl-Alt-F1 (or f2, f3) to get to a virtual console, all i get is a blank screen. nada. this goes on for a long time until i get impatient and just ctrl-alt-delete twice to restart. i've tried thrice and got the same result.

any idea why?

thanks in advance!

kilgoretrout 12-10-2003 03:12 PM

No clue why that's happening, but hitting Alt-F7 should take you back to your gui desktop. If that doesn't work, try doing Alt-Fx with x=1 through 6 and see if you can get back to the gui.

yanar99 12-10-2003 03:56 PM

Alt-Fx turned out to be shortcuts (Alt-f2 for example opens Run Program dialog).
Alt-F7 and Ctl-Alt-F7 did get me back to the gui.

One thing I noticed, though. Riight before I do a gui login, the virtualconsole login appears very, very quickly (I have a newbie book in front of me, that's how I knew it was a virtual console login). This last time, I was able to "catch" it and type my username, but just the same, it disappeared and proceeded to load the gui.

???

yanar99 12-10-2003 11:31 PM

help please, anyone?

slakmagik 12-11-2003 02:24 AM

Clueless about RH but maybe you're booting to a GUI by default and RH disables virtual consoles in that runlevel? Edit /etc/inittab to go to a console runlevel and/or add consoles to all runlevels?

Alt-F[n] cycles you through consoles - Ctrl-Alt-F[n] breaks you out of a GUI if there's any console to go to.

yanar99 12-11-2003 04:28 AM

thanks for your replies.

i tried changing the runlevel to a "3" and i got a console. i was able to play around with it fine. i "startx" and i got the gui fine. when i pressed ctl-alt-fn again to go back to the console, i got a blank screen again.

kilgoretrout 12-12-2003 12:08 AM

Post your /etc/inittab file. That's what spawns the virtual terminals on boot by calling a "getty" program located in /sbin; the common ones are getty, agetty or mingetty. Here's mine from mandrake:

Code:

#
# inittab      This file describes how the INIT process should set up
#              the system in a certain run-level.
#
# Author:      Miquel van Smoorenburg, <miquels@drinkel.nl.mugnet.org>
#              Modified for RHS Linux by Marc Ewing and Donnie Barnes
#

# Default runlevel. The runlevels used by Mandrake Linux are:
#  0 - halt (Do NOT set initdefault to this)
#  1 - Single user mode
#  2 - Multiuser, without NFS (The same as 3, if you do not have networking)
#  3 - Full multiuser mode
#  4 - unused
#  5 - X11
#  6 - reboot (Do NOT set initdefault to this)
#
id:5:initdefault:

# System initialization.
si::sysinit:/etc/rc.d/rc.sysinit

l0:0:wait:/etc/rc.d/rc 0
l1:1:wait:/etc/rc.d/rc 1
l2:2:wait:/etc/rc.d/rc 2
l3:3:wait:/etc/rc.d/rc 3
l4:4:wait:/etc/rc.d/rc 4
l5:5:wait:/etc/rc.d/rc 5
l6:6:wait:/etc/rc.d/rc 6

# Trap CTRL-ALT-DELETE
ca::ctrlaltdel:/sbin/shutdown -t3 -r now

# When our UPS tells us power has failed, assume we have a few minutes
# of power left.  Schedule a shutdown for 2 minutes from now.
# This does, of course, assume you have powerd installed and your
# UPS connected and working correctly. 
pf::powerfail:/sbin/shutdown -f -h +2 "Power Failure; System Shutting Down"

# If power was restored before the shutdown kicked in, cancel it.
pr:12345:powerokwait:/sbin/shutdown -c "Power Restored; Shutdown Cancelled"


# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6


The last six lines are for creating the virtual terminals 1 thru 6. The "respawn" in each line is important. That means that init should restart the command given in the entry when the getty process dies which is every time a user logs out. The "getty" program executes /bin/login to initiate a login session on that terminal.

JZL240I-U 12-12-2003 03:23 AM

Quote:

Originally posted by yanar99
... i "startx" and i got the gui fine. when i pressed ctl-alt-fn again to go back to the console, i got a blank screen again.
Try
Code:

startx &
Silly aside: You made sure there is no screen saver running?


All times are GMT -5. The time now is 07:55 PM.