LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Blank screen with blinking cursor on boot (yoper) (https://www.linuxquestions.org/questions/linux-newbie-8/blank-screen-with-blinking-cursor-on-boot-yoper-288538/)

Fisslefink 02-10-2005 11:15 AM

Blank screen with blinking cursor on boot (yoper)
 
I'm very new to Linux - having only used it as my main operating system for about 2 weeks, and even then, it was just a Knoppix LiveCD. Yoper is (or rather, will be) my first plunge into a hard drive installation.

After installation, all I am getting is my BIOS POST screen followed by a black screen with a blinking white cursor about 2 lines (of text) down on the top left. Num lock and caps lock work fine, as does Ctrl-Alt-Delete.

I have WinXP on a 120Gb SATA drive and a blank 10Gb IDE drive on the same machine. I have configured it to boot from the IDE drive and even gone so far as to unplug the SATA drive.

[edit] I am using Yoper 2.2.0-6 Pre-Release (think another version would be more likely to work)? [/edit]

Installation begins fine from the Yoper CD - I used Qtparted to create 4Gb root, 512Mb swap, and 5.5Gb home partitions. Installation continued, and I have tried using reiserfs4, reiserfs, and ext3 file systems, as well as trying Lilo and Grub boot agents -- nothing seems to help. I just did a 'failsafe' install, again, no luck.

The only errors I have encountered are: SAX2 failing to detect my display size (and asking me to input it in mm), and "mkdir cannot create y2/home directory" after I finish configuring everything.

Installation appears to end correctly, asking me to type "exit" and let it reboot.

My hardware:
P4 2.8Ghz
512Mb Ram
Asus P4P800-E Deluxe
Seagate 10Gb IDE hard drive
Samsung 120Gb SATA hard drive (disabled)
CTX S762G (LCD monitor)
Rosewill ATI Radeon 9600 128Mb
Logitech cordless USB mouse (have tried with old school PS/2 mouse though)

Thanks for any help!!!

- Fisslefink

Fisslefink 02-10-2005 05:12 PM

update
 
I downloaded and installed from the Yoper 2.1 ISO using reiserfs on Home and Root partitions, plus a 512Mb swap... same exact problem as before, so it's not due to the unstable Pre-Release. I guess it must be a hardware or configuration issue, but I can follow directions, and my PC isn't that unusual.

Any suggestions???

- Fisslefink

magus0216 02-10-2005 05:19 PM

I had a hardware issue with my p4p800-e. Try editing your IDE config in the bios to Enhanced Mode SATA Only and see if that fixes anything. It might have been a mandrake issue, but it's worth trying anyways.

Fisslefink 02-15-2005 06:16 PM

[solved]
 
This was solved on the Yoper.com forums -- for those who might have had a similar problem, the fix was simple.

WHY: Blank screen (with blinking white cursor) and no boot loader is caused because the BIOS sees a bootable disk but no boot flag on the partition.

FIX: Add the "boot flag" to the root partition using cfdisk before or after installation. Alternatively, set the root partition as "Active" in Qtparted before or after installation.

I did this, and it booted to LILO just fine.

Fisslefink


All times are GMT -5. The time now is 01:15 PM.