-   Linux - Newbie (
-   -   Blank screen - screen saver ??? (

cstehle 03-11-2002 04:41 PM

Blank screen - screen saver ???
When my system sits idle for about 10 minutes, the screen blanks out and my web server is not accessable. I have read numerous theads that indicate xset and setterm commands, such as: xset s off, setterm s noblank s 0, I've even tried staying in text mode rather than enter kdm, yet nothing does the trick. Help

There's gotta be something simple that I'm missing?

Thanks in Advance,

unSpawn 03-11-2002 06:21 PM

xset s noblank
xset s 0 0

works for me.

cstehle 03-12-2002 01:35 PM

Still a no-go
I've tryed the above settings but still the blank sleep mode. I also tried disabling the dpms (power settings). Any ideas, could it be a video card setting?

Looking a the xset info: blanking is set to no, timout is 0, cycle is 0, and allow exposures is set to no (I tried yes too). I also tried with the screen saver turned both on and off.

finegan 03-12-2002 01:52 PM

This sounds like a bigger problem than setterm that just deals with output to your monitor, this seems like you have apmd set to put your whole machine to sleep after a certain idle time. Does this only happen to the webserver, or do all other daemon services cack out too? Also, what distro?



cstehle 03-12-2002 02:14 PM

It appears that you are correct, smb is also down. It's redhat 7.2.

finegan 03-12-2002 02:49 PM

Its got to be something having to do with putting your machine to sleep. My guess is apmd, but I don't know much about these daemons as I've never had a problem with them.

If you:

ps aux | grep apmd

and then kill the Pid of that bugger (assuming it doesn't restart... RH does wiggy things), and the machine makes it past 10 minutes at idle then that was it.

Although, honestly I never usually suggest this, but there's probably some cute gui tool in whatever X desktop you're using that could stop it... or:

Reboot the machine, go into BIOS and disable all the cute power management feature that might be it.



cstehle 03-12-2002 02:57 PM

Thanks for the input, I disabled the APM in the BIOS, if this dosen't work I'll try the other stuff you suggested.

Thanks Again,

cstehle 03-12-2002 03:47 PM

Finegan -- you are the man! This has been driving me up the wall.

Disabling APM in the BIOS seems to have done the trick. It's been up for about an hour.

Thanks Again,

justiceisblind 03-13-2002 10:44 PM

Another way you can disable APM is in the kernel itself... if you have the kernel sources installed and run a configure on them it asks about power management and whether to enable it or disable it... (at least under slack...), and that should REALLY do the trick if nothing else works...

All times are GMT -5. The time now is 08:41 PM.