-   Linux - Newbie (
-   -   Blank Log in Screen with working mouse pointer (

ed163126 09-20-2007 08:41 PM

Blank Log in Screen with working mouse pointer
I've recently installed fedora core 6. I installed synaptic and allowed it to install the software updates that I needed. When I woke up the next morning there was a blank screen with a "working in background" mouse pointer. The pointer can move around but I cannot log in to the system. Also I set the welcome screen to change every time I log in, right before I installed the update packages with the synaptic.

What do I need to do to get back into my system?

Simon Bridge 09-20-2007 09:08 PM

Will ctrl-alt-bs take you to a text login screen?

If not: Boot from the install DVD. Enter "linux rescue" at the boot: prompt to get a root terminal.
Mount your boot partition (fedora uses LVM by default so you're probably going to have to mount the volume first). Then you can edit the /boot/grub/grub.conf so the default runlevel is 3. Reboot - remove media.

Now you should have a text login.

Log in.
Enter "startx" an the CLI prompt.

Now you can fix up your installation from the GUI.

There's also a way to set up rl3 at boot from the grub commandline but I forget.

I understand that apt for fedora is getting good ... I still advise against it. Use yum with Yum Extender (or pirut I guess) instead.

ed163126 09-20-2007 09:58 PM

If I press ctrl-alt-bs 3 times, it takes me to the command line for a few seconds, then it goes back to the blank screen. I tried ctrl-alt-F1 and that took me to the command line. I then entered "startx" and got this result:

Fatal server error:
Server is already active for display 0
If this server is nolonger running, remove /tmp/.XO-lock
and start again

Xlib: connection to ":0.0" refused by server

Xlib: Invalid MIT-MAGIC-COOKIE-1 key
giving up.

xinit: unable to connect to X server

xinit: no such process (errno3): server error

I then put the dvd in and ran "Linux rescue". Before I got to the command prompt the set up told me to enter "chroot /mnt/sysimage" to get to the root environment. After that I entered "/boot/grub/grub.conf" and got "access denied".

What should I do next?


Simon Bridge 09-20-2007 11:25 PM


I tried ctrl-alt-F1 and that took me to the command line. I then entered "startx"
... you needed to login first. I take it you didn't get a login prompt?


I entered "/boot/grub/grub.conf" and got "access denied"
That is likely because you didn't mount your installed /boot partition. Instead, you were asking to edit the rescue-mode grub.conf which is a nono.

Try fdisk -l from there and see how you've installed.

eg... if sda2 is /boot normally then you want to do:

mount -t ext3 /dev/sda2 /mnt
nano /mnt/grub/grub.conf

If fdisk shows lvm, things get more complex.

All times are GMT -5. The time now is 08:35 PM.