LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-05-2003, 12:55 PM   #1
usman
LQ Newbie
 
Registered: Jun 2003
Location: Pakistan
Distribution: Red hat 8.0
Posts: 22

Rep: Reputation: 15
blackbox help


i new to linux .. and i am using RH 8.0 .. now i installed blackbox window manager successfully .. eveything went ok .. now that its installed .. how do i shift from kde to blackbox ??? or whtever .. wht do i do now to use blackbox ?
 
Old 08-05-2003, 05:46 PM   #2
redhax8
Member
 
Registered: Jan 2002
Distribution: Debian
Posts: 43

Rep: Reputation: 15
Try editing .xinitrc (notice the dot in front of it) in your home directory.

If there is a line
startkde
then comment it out by putting a # in front of it.
Then add
exec blackbox
as the last line.

Hope this helps
 
Old 08-06-2003, 10:55 AM   #3
usman
LQ Newbie
 
Registered: Jun 2003
Location: Pakistan
Distribution: Red hat 8.0
Posts: 22

Original Poster
Rep: Reputation: 15
i cant seem to find that dir in my root .. ???
 
Old 08-06-2003, 11:28 AM   #4
killi
Member
 
Registered: Apr 2003
Location: Norway
Distribution: Diff
Posts: 440

Rep: Reputation: 30
go to /etc/X11/xinit/
and edit xinitrc or xinitrc.kde and change from startkde to exec blackbox
 
Old 08-06-2003, 12:05 PM   #5
usman
LQ Newbie
 
Registered: Jun 2003
Location: Pakistan
Distribution: Red hat 8.0
Posts: 22

Original Poster
Rep: Reputation: 15
ok .. i am sorry i am pasting the whole thing here .i already habe gnome and kde installed .. so i think i'll making changes in Xclients file
so here is my file and made a few changes take a look at it and please help me out here .


[root@localhost xinit]# cat Xclients
#!/bin/bash
# Copyright 1999 - 2001 Red Hat, Inc.
# License: GNU General Public License v2

# check to see if the user has a preferred desktop
PREFERRED=
if [ -f /etc/sysconfig/desktop ]; then
. /etc/sysconfig/desktop
if [ "$DESKTOP" = "GNOME" ]; then
PREFERRED=gnome-session
elif [ "$DESKTOP" = "KDE" ]; then
# PREFERRED=startkde
exec blackbox
elif [ "$DESKTOP" = "WINDOWMAKER" ]; then
PREFERRED=wmaker
fi
fi

if [ -n "$PREFERRED" ] && which $PREFERRED >/dev/null 2>&1; then
PREFERRED=`which $PREFERRED`
exec $PREFERRED
fi

# now if we can reach here, either no desktop file was present,
# or the desktop requested is not installed.

if [ -z "$PREFERRED" ]; then

GSESSION=gnome-session
# STARTKDE=startkde
STARTKDE = blackbox
# by default, we run GNOME.
if which $GSESSION >/dev/null 2>&1; then
exec `which $GSESSION`
fi

# if GNOME isn't installed, try KDE.
if which $STARTKDE >/dev/null 2>&1; then
exec `which $STARTKDE`
fi
fi

# Failsafe.

# these files are left sitting around by TheNextLevel.
rm -f $HOME/Xrootenv.0
rm -f /tmp/fvwmrc* 2>/dev/null

# First thing - check the user preferences
if [ -f $HOME/.wm_style ] ; then
WMSTYLE=`cat $HOME/.wm_style |tr A-Z a-z`
case "$WMSTYLE" in
afterstep|windowmaker|mmaker)
exec /usr/X11R6/bin/RunWM --WindowMaker
;;
fvwm95|fvwm|fvwm2)
exec /usr/X11R6/bin/RunWM --Fvwm95
;;
mwm|lesstif)
exec /usr/X11R6/bin/RunWM --FvwmMWM
;;
esac
fi

# Argh! Nothing good is installed. Fall back to fvwm2 (win95-style) or twm
/usr/X11R6/bin/RunWM --Fvwm95 || {
# gosh, neither fvwm95 nor fvwm2 is available;
# fall back to failsafe settings
xclock -geometry 100x100-5+5 &
xterm -geometry 80x50-50+150 &
if [ -f /usr/bin/mozilla -a -f /usr/share/doc/HTML/index.html ]; then
mozilla /usr/share/doc/HTML/index.html &
fi
if [ -f /usr/X11R6/bin/fvwm ]; then
exec fvwm
else
exec twm
fi
}
 
Old 08-06-2003, 12:54 PM   #6
killi
Member
 
Registered: Apr 2003
Location: Norway
Distribution: Diff
Posts: 440

Rep: Reputation: 30
there is a prog in red hat dont remember the prog
havent tried red hat
 
Old 08-07-2003, 12:10 PM   #7
redhax8
Member
 
Registered: Jan 2002
Distribution: Debian
Posts: 43

Rep: Reputation: 15
In your home directory create a file named
.xinitrc
The only line that has to be there is
exec blackbox
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
BlackBox look shoki_neu Linux - Software 0 05-21-2004 05:23 AM
blackbox? Alderian Linux - Newbie 1 08-23-2003 04:37 AM
Blackbox Drogo Linux - Software 25 06-18-2003 06:15 PM
Blackbox Smog Linux - Software 14 06-17-2003 04:11 PM
blackbox lil_becky Linux - Software 7 11-17-2002 12:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration