-   Linux - Newbie (
-   -   Black screen installing Mandrake 9 (

clothocan 12-20-2002 09:00 PM

Black screen installing Mandrake 9
Before somebody jumps to any conclusions, it's not the command prompt. There is no prompt of any kind. It starts up with the initial 'press enter to run setup' and another option graphical interface. I press enter... monitor screen goes black and caps lock key flashes for about 5-10 minutes, then everything goes silent.
It appears that the monitor is still getting a signal, because the power led stays green, instead of flashing amber.
Now, I would just love to blame it on the cd and download it again, but after several attempts at installing this, including by using the command-line startup of the installer and trying lovidmem (I think that's what it said, I figured it was worth a try), I got fed up and tried it on another pc. Less than half an hour later I had an up-and-running Mandrake 9 installation.
Knoppix runs fine on the machine that Mandrake won't install to, and Debian will at least begin the install (corruped iso-I won't go there)

I could really use a hand here.

tha_newbfather 12-20-2002 09:05 PM

Sorry, you say there is a *second* graphical interface screen ... what was on that, and what are you slecting by pressing enter at that stage?

clothocan 12-20-2002 09:10 PM

My apologies. What I meant was that there are two *options*, not two screens. There's the 'press enter', and another one where you can add command line options.

tha_newbfather 12-20-2002 09:15 PM

Right --

hit f1 at that screen, and then try entering this:

linux pci=bios

May or may not help, but give it a shot. There's obviously not a whole there to diagnose what the problem really is -- but that's hardly your fault!

Good luck

clothocan 12-20-2002 10:40 PM

loading vmlinuz.....................
loading something else.......................

black screen, flashing capslock. :(

tha_newbfather 12-20-2002 10:51 PM

Sorry, I've got nothing.

whansard 12-21-2002 02:48 AM

try booting with the other video modes or try vesa
look at what options the knoppix cdrom uses and
try those. if you make a knoppix bootable floppy
they will be in syslinux.cfg i think

clothocan 12-21-2002 10:30 AM


Krmshnibble forgen gibble bobble? Newbie, remember? :)

whansard 12-21-2002 08:39 PM

DEFAULT vmlinuz
APPEND lang=us ramdisk_size=100000 init=/etc/init noapic apm=power-off hda=scsi hdb=scsi hdc=scsi hdd=scsi hde=scsi hdf=scsi hdg=scsi hdh=scsi vga=791 initrd=miniroot.gz quiet BOOT_IMAGE=knoppix

thats part of the knoppix syslinux.cfg
i was just hoping that maybe something in there that
helps your machine boot would halp mandrake boot
those options would be passed to the kernel when
you press f1 to boot mandrake and type something
vmlinuz setup vga=491 noapic apm=power-off

replace the vmlinuz setup with whatever mandrake
says you need to type to start set or install.

clothocan 12-21-2002 10:02 PM


after trying every possible option two or three times and in a multitude of different combinations, the 'text' switch worked for the installation. Which is odd, because the first time I tried, it did the same as all the rest. The installation went smoothly except it didn't give me any options as to what packages I wanted to install. No big deal there.
Now I just have no X. WHEEEEEEE!!!

whansard 12-21-2002 11:19 PM

run Xconfigurator
or XF86Setup
or other suggestions you will get here
if it never does set up right
you can copy your XF86Config from your knoppix
that works to a floppy and put it in the mandrake
its in /etc/X11/

All times are GMT -5. The time now is 11:49 PM.