LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-12-2017, 02:32 PM   #1
rooman
Member
 
Registered: Mar 2002
Location: Lausanne, Switzerland
Distribution: Mandriva 2007.0
Posts: 233

Rep: Reputation: 30
Black screen every time I try to configure graphics with drakconf


After many different error messages concerning X, rights and the wrong number of devices detected,etc,
I deleted Xauthority files as suggested in a post, did a chown on my account and tried drakconf several times.
Each time I test the graphics setup or validate it goes to black screen. Drakconf detects an older card than is installed, I've tried disabling all options, small resolutions and the nv and nouveau drivers.
Nothing works.
Help please, must I reinstall?

Mageia 6, KDE stock clean install

Last edited by rooman; 10-12-2017 at 02:34 PM.
 
Old 10-12-2017, 06:21 PM   #2
JeremyBoden
Senior Member
 
Registered: Nov 2011
Location: London, UK
Distribution: Debian
Posts: 1,887

Rep: Reputation: 467Reputation: 467Reputation: 467Reputation: 467Reputation: 467
My first encounter with Linux was Mandrake/Mandriva many years ago...
It had all these Drake configurators, which were quite unstable.

So I moved on.

Ubuntu was getting good reviews (at that time).
Never used KDE, but I would suggest trials of Mint, Debian or LMDE.
 
Old 10-13-2017, 02:33 PM   #3
X-LFS-2010
Member
 
Registered: Apr 2016
Posts: 510

Rep: Reputation: 58
I would say yes if your a newbie and it doesn't work ... try Ghost BSD or Ubuntu / Fedora linux'es.

xorg-server setup was (maybe is still) infamous for giving people the black screen - and some distro admins (ie ubuntu) accused the victims and close (prevented further discussion)

The problem there? People's keyboard (or moreso mouse) were not detected by xorg in a timely manner, xorg would give a black screen but xorg HAS A BYPASS for that (see xorg's documentation) that allows startup "without keybaord and mouse". When used it worked because xorg did detect them it just didn't detect them quickly enough before that "check", thus many many people were getting black screens - and many chose to go to win10 or macOS Sierra thinking linux were a bunch of liars.

personally i'd still like to hear why/how that major incident, which went on for years, all went down (noting X11R6-4.8.0 never had such a problem. i mean: they added the problem and didn't tell new users about it when asked. very strange.)

Last edited by X-LFS-2010; 10-13-2017 at 02:34 PM.
 
Old 10-15-2017, 10:22 AM   #4
rooman
Member
 
Registered: Mar 2002
Location: Lausanne, Switzerland
Distribution: Mandriva 2007.0
Posts: 233

Original Poster
Rep: Reputation: 30
I'm not a newbie after more than 10 years, just a normal user willing to try to use and promote linux.
My sytem was working okay and I was flying the Flightgear simulator regularly with a little o/c on the cpu and agressive settings in the nvidia config utility.

There are certainly bad things (parameters, drivers) that must be eradicated so as to configure correctly my card and monitor, that's my challenge but I know I'need help.
 
Old 10-17-2017, 12:24 AM   #5
rooman
Member
 
Registered: Mar 2002
Location: Lausanne, Switzerland
Distribution: Mandriva 2007.0
Posts: 233

Original Poster
Rep: Reputation: 30
Anyone know how to purge and reinstall all X11 and NVIDIA files in a console using urpm or dnf?
 
Old 10-19-2017, 04:52 AM   #6
rooman
Member
 
Registered: Mar 2002
Location: Lausanne, Switzerland
Distribution: Mandriva 2007.0
Posts: 233

Original Poster
Rep: Reputation: 30
Thanks all, I've reinstalled with Gnome, looks okay for now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Black screen after using hot HDMI cable. Graphics card broken? duplex Linux - Hardware 4 12-27-2013 01:27 PM
Black screen after boot - Intel i830 graphics @ IBM Thinkpad R31 chooch Linux - Laptop and Netbook 7 08-19-2012 11:58 AM
Arch Linux over time Screen jitter then black screen teek Linux - General 4 01-26-2010 12:57 PM
Black Screen on reboot after enabling graphics Dugon143 Linux - Newbie 11 10-14-2007 12:51 PM
Help! Black screen instead of login screen! Intel integrated graphics coolblue SUSE / openSUSE 10 05-03-2007 05:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration