LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Black screen, blinking cursor, 'asking for cache data failed';after Ubuntu update (https://www.linuxquestions.org/questions/linux-newbie-8/black-screen-blinking-cursor-asking-for-cache-data-failed%3Bafter-ubuntu-update-4175491456/)

nutoubuntu 01-16-2014 02:46 AM

Black screen, blinking cursor, 'asking for cache data failed';after Ubuntu update
 
Hi all,
New to linux, ubuntu, and this forum.
I have enjoyed ubuntu for the past few months, but after my last update installation ubuntu would boot to a black screen and blinking cursor. If I let it sit for a while it would give the following:
12.3456789 sd 6:0:0:0 [sdb] assuming drive cache: write through
.............................asking for cache data failed
It would then repeat the lines above but the numbers would get higher.
It would never boot.

I tried a live backtrack and knoppix usbs, and when trying to access my ubuntu files I get:
THIS DIRECTORY HAS BEEN UNMOUNTED TO PROTECT YOUR DATA.

From the graphical desktop, click on:
"Access Your Private Data"

or

From the command line, run:
ecryptfs-mount-private

---
Running the above in a terminal gave me this:ERROR: Encrypted private directory is not setup properly

I would ideally want to solve this problem and boot back into ubuntu, but if not, I really want to get my files off the hard drive so I can save them before I wipe and reinstall(yes, I should have backed up:()

I have tried to edit the grub with nomodeset and rmmod the ums_realtek, and a few other things I have found with google. None have worked so far.

Any suggestions on how to get my files back or even fix this?

Thanks a million from a newbie.

EDDY1 01-16-2014 02:58 AM

Are you able to run Ubuntu in rescue mode from grub?

qrange 01-16-2014 03:00 AM

I'd try to fsck the partitions from LiveCD/USB. would be a good idea to make a complete backup with dd first.

nutoubuntu 01-16-2014 03:01 AM

Yes I am.
I used the rescue mode to get to the terminal to run the fsck. I was just blindly following another forum post I read, but it was not successful.

nutoubuntu 01-16-2014 02:34 PM

additional
 
I let the computer run all night in an attempt to boot, it gave the same 'asking for cache data failed, but it ran through hundreds and hundreds of lines.
The numbers increased with each error report, the first was 55.xxxxxxx I believe, and this morning it was at about 9000.xxxxxxx, it gave a new identical report every minute or so but the numbers would increase anywhere from a few to a few hundred with each report..

EDDY1 01-18-2014 02:50 AM

What was the error?


All times are GMT -5. The time now is 11:33 PM.