-   Linux - Newbie (
-   -   Bad Magic Number (

I Use Dial 07-18-2009 12:00 PM

Bad Magic Number
I'm not really sure all the info I should provide for this, but here's the story, or scroll to bottom for meat of problem.

I had Ubuntu 8.04 64-bit on a 60 GB PATA drive and 2 250 GB drives with information I'd rather not lose (was not RAID).

Old mobo had issues. I tried to install two 1 TB drives and couldn't get the mobo to see all 4 drives in bootup. Tried to make the 1 TB drives into a RAID. The mobo RAID 'utility' I'm pretty sure didn't touch the 250 GB drives.

Thought updating BIOS would fix problem, but flash utility only worked in Windows. So I installed Windows and despite dozens of previous successful flashes, proceeded to screw up the flash. IIRC, I had the 250 GB drives disconnected for this.

I then bought a new mobo and installed Ubuntu 8.04 again on the 60 GB. After getting an mdadm RAID set up with the 1 TB drives, I installed and mounted the 250 GB drives.

I can see no information on the 250 GB drives, but GParted shows that there is information stored on the drives (I did not partition the drives).

When I run dmesg I can see:


XFS: bad magic number
SB validate failed
XFS: bad magic number
SB validate failed
I ran xfs_repair but it fails to find a suitable superblock.

Is there anything more I can do?

JZL240I-U 07-28-2009 07:02 AM

One of these might help:

Your choice. Good luck.

All times are GMT -5. The time now is 07:31 PM.