LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Automatically mount Windows partition with full access? (https://www.linuxquestions.org/questions/linux-newbie-8/automatically-mount-windows-partition-with-full-access-368892/)

Josh1billion 10-01-2005 09:48 PM

Automatically mount Windows partition with full access?
 
I need to set my configurations up so that my NTFS Windows partition (hda1) automatically mounts so I can access the files everytime I log in from any username (though I'm planning on only using my regular non-root username most of the time).

I've used this guide: linux.org.mt/article/winmount (sorry, I can't link the URL since this is my fifth post and any posts under fifth with a URL will be blocked on these forums, apparently).

That guide works fine, except for the fact that the partition is never mounted on startup (scroll down to the next paragraph for more details on this*), and then I manually mount it, and the folder containing the Windows files is protected so only root can access it. I need to be able to access it from my non-root username.

Quote:

3. If that worked, you can make it easier or automatic to mount by adding the following line to /etc/fstab:

/dev/hda1 /c vfat noauto,user 0 2
*I did this, but every time I log in and go edit that file again, that line is gone again. :confused:

Thanks in advance for the help. :)

aysiu 10-01-2005 10:09 PM

It really depends on what distro you're using, but here's the Ubuntu instructions:

http://ubuntuguide.org/#automountntfs

Should be adaptable for other distros. NTFS will be read-only, though, whatever distro you're using.

Josh1billion 10-01-2005 10:11 PM

Thanks, I'll try that. I'm using Fedora Core 4.

aysiu 10-01-2005 10:13 PM

Quote:

Originally posted by Josh1billion
Thanks, I'll try that. I'm using Fedora Core 4.
It's actually a bit more complicated in FC4, because you have to enable NTFS support first.

Try this instead:

http://www.linuxquestions.org/questions/history/363909

Josh1billion 10-01-2005 11:26 PM

No problem, I've already enabled it beforehand (while I was trying to get the first guide in my topic post to work, last night).

Hosiah 10-02-2005 12:37 AM

Well, on my dual-boot Red Hat/Windows machine, I do:

Quote:

/dev/hda1 /mnt/win vfat user,umask=0 0 0
in the last line of /etc/fstab. This enables all users to read/write to/from the Windows hard-drive.

aysiu 10-02-2005 12:41 AM

vfat is for FAT partitions, not NTFS.


All times are GMT -5. The time now is 11:07 PM.