LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-24-2012, 07:09 AM   #1
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 613

Rep: Reputation: 34
Auto mounting file system


Hi, I am using Redhat 5 and I have 4 additional filesystem which get mounted at the boot time even though there is no entry in the /etc/fstab

can some one tell me how this is done

Thanks and regards
 
Old 10-24-2012, 09:16 AM   #2
epislav
LQ Newbie
 
Registered: Jun 2012
Posts: 20

Rep: Reputation: Disabled
Try looking at /etc/auto.* files
They are related to autofs
 
Old 10-24-2012, 09:19 AM   #3
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, CoreOS, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 7,064
Blog Entries: 14

Rep: Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248
Showing us df -h output for the filesystems in questions would help. The previous reply assumes these are NFS mounts.

It could be some other script doing the mount for specific purposes - I've seen many a loopback mounted that way. Looking in /etc/init.d for any script that runs the "mount" command might help you figure out what it is if it isn't an auto NFS mount. (Auto NFS by the way should only mount filesystems when they are accessed as that is the point - when not in use autofs filesystems unmount themselves.)
 
Old 10-24-2012, 01:11 PM   #4
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 613

Original Poster
Rep: Reputation: 34
Hi Guys, thanks for the reply

# df -h .
/dev/cciss/c0d0p10 67G 4.8G 59G 8% /media/_working_files

# e2lable /dev/cciss/c0d0p10
/working/files

I checked /etc/init.d for any custom mount scripts but not things is out of place though

Thanks and regards
 
Old 10-24-2012, 03:12 PM   #5
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, CoreOS, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 7,064
Blog Entries: 14

Rep: Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248
If you're using the disk label it is possible the mount in /etc/fstab is using that rather than the disk name.

For example I have /boot on a system showing up in df -h as:
Filesystem Size Used Avail Use% Mounted on
/dev/cciss/c0d0p1 99M 28M 66M 30% /boot

But the actual entry in fstab is:
LABEL=/boot /boot ext3 defaults 1 2

That is to say there is no direct mention of /dev/cciss/c0d0p1 in fstab because it is using the label instead.

Perhaps you have a line starting "LABEL=/working/files" in your fstab?
 
Old 10-30-2012, 04:05 AM   #6
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 613

Original Poster
Rep: Reputation: 34
Hi MensaWater, this is the first thing that I checked, I dont see any thing related to this file system in the /etc/fstab

Strange though every time the system boots up this file system gets mounted but I am unable to find any trace how this is getting mounted

Thanks and Best Regards
 
Old 10-30-2012, 06:33 AM   #7
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,417

Rep: Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397
As epislav indicated, start with looking at /etc/auto.master
http://linux.die.net/man/5/auto.master
http://linux.die.net/man/8/automount5
http://linux.die.net/man/5/autofs
 
Old 10-30-2012, 11:12 AM   #8
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, CoreOS, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 7,064
Blog Entries: 14

Rep: Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248
It might be helpful if you posted the full output from your /etc/fstab and /etc/auto* files.
 
Old 10-31-2012, 12:42 AM   #9
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 613

Original Poster
Rep: Reputation: 34
Hi Guys, since the cat output of all auto files are attached with a file name auto_file

Thanks and Regards
Attached Files
File Type: txt auto_file.txt (9.8 KB, 38 views)
 
Old 10-31-2012, 10:58 AM   #10
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, CoreOS, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 7,064
Blog Entries: 14

Rep: Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248
It appears you're right that none of those is doing the mount.

Did you ever check the scripts in /etc/init.d to see if any of those are doing a mount command (other than the standard ones)? I'd mentioned that in my initial reply. Doing a grep working/files /etc/init.d/* would probably be best to check for this since that is the mounted filesystem's name.

You might also want to check your cron files to see if any of those are doing it.

Also although seldom used for such purposes these days it is barely possible you have a script being called by /etc/inittab doing the mount so you can look there to rule it out.

Of course its possible that one of your scripts is calling another one that is doing the mount so it may be harder to find because you'd have to look at levels. Also it is possible that you have a completely separate server doing an ssh into this one to do the mount and that would be even harder to find. You could try manually unmounting the filesystem then removing the mount point directory so the mount fails when attempted to see if you get an error message on boot or start getting errors in /var/log/messages or cron log or somewhere else when it tries to do the mount.
 
Old 11-02-2012, 01:38 AM   #11
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 613

Original Poster
Rep: Reputation: 34
Hi, found some information hope this will help,

Every time I change the volume label (using e2lable) it uses this information to create a mount point under /media/XXXXXXX to auto mount the FS

Say I changed the volume label e2label /dev/cciss/c0d0p1 /home/yyy
then I go about rebooting the server, then I can see this filesystem is mounted under /media/yyy

Have no idea what is going on and I am unable to find any script that might do this ((

Thanks and Regards
 
Old 04-06-2013, 12:11 PM   #12
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 613

Original Poster
Rep: Reputation: 34
Hi Guys, I know this is an age old question but I failed to find any reason for this file system to auto mount with out any entry in /etc/fstab (((, I am totally lost. Any help appreciated

Thanks and Best Regards
 
Old 04-06-2013, 01:22 PM   #13
johndears
LQ Newbie
 
Registered: Nov 2012
Posts: 6

Rep: Reputation: Disabled
...

Last edited by johndears; 04-06-2013 at 01:48 PM.
 
Old 05-30-2013, 06:19 AM   #14
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 613

Original Poster
Rep: Reputation: 34
Hi, can it be this gnome-volume-manager doing this auto mounting under media, think that this hard disk partition is a removable

I need help

Thanks and Regards
 
Old 06-13-2013, 02:11 AM   #15
procfs
Member
 
Registered: Jan 2006
Location: Sri Lanka
Posts: 613

Original Poster
Rep: Reputation: 34
Hi This only happens if I Label the file system, I have removed all the Labels and called the device name from the fstab and it worked

Dont know why, as soon as I label the filesystem it automatically gets mounted at the reboot time under /media directory even there is no corresponding entry in fstab file

Thanks and Best Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] how to auto mount a file system on reboot gvsbnarayana Linux - Newbie 6 11-05-2011 09:37 AM
USB pen drives not auto prompting or auto mounting on KDE3.5 (PCLOS) k.king Linux - General 1 03-17-2009 04:16 PM
Problems with screen resolution, auto-mounting hda1, unable to save file meiya Debian 1 01-09-2006 10:57 AM
auto mount samba file system nanjil SUSE / openSUSE 1 11-25-2005 11:19 AM
Newbie Question - Auto mounting of server share file dodjie60 Linux - Networking 15 09-12-2005 10:34 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration