LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Authenticating users on Proftpd (https://www.linuxquestions.org/questions/linux-newbie-8/authenticating-users-on-proftpd-45091/)

wallaba 02-12-2003 11:09 AM

Authenticating users on Proftpd
 
Hi,

I'm trying to setup a proftpd server. I'm using the one that comes with mandrake 9, installed by mandrake, however, whenever i try and remotly log in using one of the user/pass on my system, it always says invalid user name/pass. Is there some configuration i'm missing? I read the FAQs around the net and the only solution they suggested was check my PAM settings, and my pam settings (etc/pam.d/ftp) are EXACTLY how they are in those FAQs, so i'm wonderin gwhat is wrong here.

also another small question, maybe its just me, i've had very little sleep lately, but the userguide on the proftpd website just looks like a bunch of unasnwered e-mail question strung together, am i missing something there?

Wallaba

acid2000 02-12-2003 02:12 PM

I never got proftpd to work properly, Have you tried pure-ftpd. Worked out of the box for me.

marsonist 02-12-2003 06:31 PM

For proftpd I have always cheated and used the webmin dialogs to set it up. www.webin.com

--Steve

trickykid 02-12-2003 07:01 PM

Quote:

Originally posted by acid2000
I never got proftpd to work properly, Have you tried pure-ftpd. Worked out of the box for me.
When replying try to be more constructive and give better advise instead of just recommending another FTP server. Just a thought as we try to answer questions here instead of recommend something totally different or RTFM type answers.

But wallaba,

How are you trying to connect to your FTP server ? Thru a client or browser ? Does this user your trying to login with actually exist as a user on your system. As far as I know there is no configuration, usually if you have proftpd setup and user accounts, they should by default be able to ftp to their home directory.

Let us know, more details will help us out.

wallaba 02-17-2003 02:08 AM

Hi,

k i tried pureftp, it works fine, its nice and simple but a little too simple for my liking, and i'm not a commandline configure fan, but imma use it until i get my proftpd working.

Yes, the users i try logging in as do exist, they work on pureftp but not on proftpd. When i log in it just says that the username or pass was invalid. I tried checking the proftpd logs, but i couldn't find them ;), i looked in /var/log/proftpd/ but the directory was empty.

If it works in pureftp but not in proftpd its either saying somthing about my proftpd setup or the authentiacion method i use for proftpd (PAM i blieve) ( cuz pureftp uses /etc/passwd right? )


All times are GMT -5. The time now is 07:55 PM.