LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   audiocd:/ in Konqueror (https://www.linuxquestions.org/questions/linux-newbie-8/audiocd-in-konqueror-47292/)

AndyJ 02-26-2003 04:16 PM

audiocd:/ in Konqueror
 
Using Suse 8.1.
When I'm logged in as root, viewing audio cds through Konqueror using audiocd:/ works fine. When logged in as a user it just won't show them. I've added the user to group 'disk' as instructed; I've tried audiocd:/?device=/dev/sr0 (it's a CDRW using SCSI emulation) but it won't recognise it:
"An error occured while loading audiocd:/?device=/dev/sr0::

The file or directory / does not exist."

I can play them fine using KsCD as a user. I'm guessing it's a security problem but I don't know what.

Has anyone got any ideas? Thanks

snocked 02-27-2003 06:35 AM

I have the same problem, except it doesn't work in root or user.

twan 02-27-2003 09:50 AM

i have the same problems

i can view every cd but no audio cd's. Not in the standard cd player, not in XMMS

AndyJ 02-27-2003 12:36 PM

Ok, managed to resolve it myself. Here's the solution for snocked, twan and anyone else who might be interested.

Given that it would work with root but not <user> I figured it had to be a permissions problem or some other security thing.

Opened a shell and in /dev/ ls -l sr0 to see what the permissions where. These where fine - owned by <user> group disk with appropriate permissions.

ls -l sg0 gave owned by root group disk with appropriate permissions. This seemed ok - <user> was a member of group disk.

Stumped I turned to the net: someone has posted about changing owner to <user> so I tried that. now sg0 is owned by <user> with appropriate permissions (rw).

Bingo!! It works now.

Not sure why it wouldn't work with the group disk (it had r permission only set)?
Not sure why need to modify device sg0? The guy who posted the answer (Patrick - kudos) merely states that sgx are to do with audio cd things.

Anyway it works - I'll worry about why later on.

twan 02-27-2003 02:56 PM

thanks! i'll try it tomorrow


All times are GMT -5. The time now is 04:54 AM.