-   Linux - Newbie (
-   -   Audio when logged in as root, not when normal user? (

LDJ 01-12-2007 04:17 PM

Audio when logged in as root, not when normal user?
Having started off just doing everything as root (I know!) i've now created a normal user account for day to day use. however, almost nothing works, LOL!

The most significant of which is I have no audio when im logged in as a standard user (created using the 'adduser -d /home/ldj/ ldj' command, but i do when im logged in as root.

what do i need to do to 'enable' audio? im guessing as audio works as root its a permissions issue?
When i run xmms from a terminal i get the error:

** WARNING **: oss_open(): Failed to open audio device (/dev/dsp): No such file or directory

If anyone can shed some light on this blighter it would be appreciated.


pljvaldez 01-12-2007 04:55 PM

Add yourself to the "audio" group. You probably also want to be part of groups like video, cdrom, etc.

LDJ 01-12-2007 05:03 PM

Thanks, done that to those three groups but it is still giving the same error.
Tried rebooting to see if it helps but no joy :(

All times are GMT -5. The time now is 07:53 AM.