LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-10-2019, 06:52 PM   #1
Noonehar
LQ Newbie
 
Registered: Mar 2019
Posts: 1

Rep: Reputation: Disabled
Exclamation Audio issues in arch-like system


i have a recently installed parabola OS (basically arch with openrc) on my LENOVO 3134A11 and since the begging i have no audio in the system. The thing is that when i run `pavucontrol` the emergent window frozen in "Establishing connection to PulseAudio. Please wait." and trying any `pactl` variants says "Connection refused". Seeing this i went to `alsamixer` to see what's happening so i put everything to the maximum and notice that increasing-decreasing "Rear mic" with loopback enabled causes noise in the speaker so i think what that means is that the system and alsa recognizes the driver, but i still have no audio.

There is some general info that i hope help to solve the problem:

Kernel version: 4.20.11-gnu-1


lspci -v:
Code:
    00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
	        Subsystem: Lenovo 6 Series/C200 Series Chipset Family High Definition Audio Controller
        	Flags: bus master, fast devsel, latency 0, IRQ 31
	        Memory at fe600000 (64-bit, non-prefetchable) [size=16K]
	        Capabilities: <access denied>
	        Kernel driver in use: snd_hda_intel
	        Kernel modules: snd_hda_intel
aplay -l:
Code:
 aplay: device_list:272: no soundcards found...
amixer
Code:
    amixer: Mixer attach default error: No such file or directory
sudo aplay /usr/share/sounds/alsa/Front_Center.wav
Code:
    ALSA lib pcm_direct.c:1966:(snd1_pcm_direct_parse_open_conf) The field ipc_gid must be a valid group (create group audio)
    aplay: main:828: audio open error: Invalid argument
("root" user has the same issues)
find /lib/modules/`uname -r` | grep snd-hda-intel
Code:
   /lib/modules/4.20.11-gnu-1/kernel/sound/pci/hda/snd-hda-intel.ko.xz
alsa force-reload
Code:
   bash: alsa: command not found
cat /proc/asound/modules
Code:
    0 snd_hda_intel
cat /proc/asound/version
Code:
  Advanced Linux Sound Architecture Driver Version k4.20.11-gnu-1.
cat /proc/asound/cards
Code:
     0 [PCH            ]: HDA-Intel - HDA Intel PCH
                          HDA Intel PCH at 0xfe600000 irq 31
Hope that you guys can find this out!

**SOLUTION**

It turns out that for some god-knows-why reason pulseaudio didn't start on startup (thats why running pavucontrol frozens the window either in normal and root, pactl din't worked, etc). After initialize pulseaudio with `pulseaudio --start` it turns out another problem: audio only works in root, so after a little research i discover that i can add audio group manually with no issues with `sudo groupadd audio`(i thought that it has to come "by fabric") and `sudo gpasswd -a *user* audio`, then i just reset and woosh audio.

Last edited by Noonehar; 03-10-2019 at 10:41 PM. Reason: Solved by myself
 
Old 03-13-2019, 11:01 AM   #2
joe_2000
Senior Member
 
Registered: Jul 2012
Location: Aachen, Germany
Distribution: Void, Debian
Posts: 1,013

Rep: Reputation: 305Reputation: 305Reputation: 305Reputation: 305
Great that you solved it and welcome to LQ!
Please mark your thread as "solved".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Arch Anywhere ISO Lets You Install a Fully Custom Arch Linux System in Minutes LXer Syndicated Linux News 0 01-22-2017 11:45 PM
Is Arch like Gentoo? Can I recompile the base system for my system? Easily? Holering Arch 7 09-09-2010 06:02 AM
Trying to install Arch with 2.6.30-ARCH kernel but uname -r keeps showing 2.6.28.7 PaulFXH Arch 0 08-20-2009 07:58 AM
Arch user wanted to help padawan learner install arch and use it thomas-linuxing Linux - Software 9 10-18-2006 04:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration