-   Linux - Newbie (
-   -   Audio in Ubuntu not working (

ummyeah 06-23-2005 02:34 AM

Audio in Ubuntu not working

I'm just trying out this crazy Linux thing now that Windows screwed up (again).

Here is the situation:

I installed Ubuntu Linux but I get no sound.None at all.
I have an onboard audio chipset (VIA 8233 AC'97). The weird thing is that Knoppix 3.7 had fully-working audio.

Is there any way I can get sound?

I'd really appreciate if anyone could tell me.I must warn you ,though, that while I'm comfortable tinkering with windows,my experience with Linux is mainly through Knoppix--copying files off dead hard druves. :o

Zeistler 06-23-2005 03:22 AM

First you need to check if the correct driver has been loaded.

open a terminal and type: su root
this command logs you in as administrator
once you're logged in as root type: lsmod
this will show all modules (drivers) that the linux kernel has currently loaded.
According to the official documentation available here:
the name of your sounddriver is: snd-via82xx
Check the list to see if it is there.

If it is in the list your problem probably has to do with the volume setting. The sound system sometimes defaults to zero. A detailed volume setting can be seen by typing: alsamixer

If it is not loaded you can try and load it manually: modprobe snd-via82xx
If it loads successfully ( i.e. no error message) run alsamixer to check the volume.

ummyeah 06-23-2005 01:48 PM

Thanks for the clear answer.

I couldn't get it to work though :(

I opened terminal and typed "su root" (no quotes,of course) and the "lsmod" like you said. This is (what I assume) to be the audio stuff:

snd_via82xx            25248        2
snd_ac97_codec        64608  1 snd_via82xx
snd_pcm_oss            47652      1
snd_mixer_oss          16768      2 snd_pcm_oss
snd_pcm                84872        3 snd_via82xx,snd_ac97_codec,snd_pcm_oss
snd_timer              23300        1 snd_pcm
snd_page_alloc          9604      2 snd_via82xx,snd_pcm
tsdev                  7488  0
gameport                4608        1 snd_via82xx
snd_mpu401_uart        7168  1 snd_via82xx
snd_rawmidi            22944      1 snd_mpu401_uart
usbhid                29376  0
snd_seq_device          8332    1 snd_rawmidi

snd                    50276            9              snd_via82xx,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device

soundcore              9824      3 snd

I tried alsamixer and turned everything up but no luck.

I tried reloading the module...same thing.

Is this a bug or just my newbie-ness?

Zeistler 06-23-2005 04:02 PM

Ok hmmm......

When you run xmms (for example) and you try and play some music what exactly happens? Does xmms freeze up or does it act like it is playing something ( i.e. the bars in the upperleft window moves up and down)?

masand 06-23-2005 06:05 PM

try this

All times are GMT -5. The time now is 06:03 PM.