LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-28-2003, 10:42 AM   #1
Knytemare4
LQ Newbie
 
Registered: Feb 2003
Posts: 5

Rep: Reputation: 0
Audigy install error


I have an audigy card. When I try to do a "make install" I get this error:

** The driver was succefully compiled, now install it with:
** make install
**
mkdir -p //lib/modules/2.4.19-16mdk/kernel/drivers/sound/emu10k1
install -c -m 664 emu10k1.o //lib/modules/2.4.19-16mdk/kernel/drivers/soun 0k1
install -c -m 664 ac97_codec.o //lib/modules/2.4.19-16mdk/kernel/drivers/s
/sbin/depmod -a 2.4.19-16mdk
/sbin/modprobe -r emu10k1.o ac97_codec.o
ac97_codec.o: Device or resource busy
make: *** [install] Error 1

If anyone can help I would really appreciate it.

Thanx
 
Old 02-28-2003, 12:07 PM   #2
johan the olive
Member
 
Registered: Feb 2003
Posts: 98

Rep: Reputation: 15
do you have it already installed?
 
Old 02-28-2003, 12:14 PM   #3
watashiwaotaku7
Member
 
Registered: Oct 2002
Location: wisconsin -- The Badger state
Distribution: gentoo
Posts: 654

Rep: Reputation: 30
are you sure there isnt already support for your card built into the kernel? that would cause that type of error and i think mandrake kernel usually has emu10k1 and probly ac97_codec you might simply try recompiling your kernel
 
Old 02-28-2003, 12:17 PM   #4
Knytemare4
LQ Newbie
 
Registered: Feb 2003
Posts: 5

Original Poster
Rep: Reputation: 0
Yeah. Im using mandrake and I already have sound. But I don't have EAX. Unless I'm mistaken, I thought the Creative Opensource drivers had support for EAX.
 
Old 02-28-2003, 12:23 PM   #5
watashiwaotaku7
Member
 
Registered: Oct 2002
Location: wisconsin -- The Badger state
Distribution: gentoo
Posts: 654

Rep: Reputation: 30
it looks though like you are using drivers that are standard with the kernel, if you want to try a different driver alsa drivers usually have more features (in the next major kernel change -2.6.0- oss will be deprecated) so you might want to try that in which case go to www.alsa-project.org might be .com and make sure youve recompiled your kernel or unloaded the modules for oss because they give alsa drivers problems
 
Old 02-28-2003, 12:28 PM   #6
Knytemare4
LQ Newbie
 
Registered: Feb 2003
Posts: 5

Original Poster
Rep: Reputation: 0
I'll give that a shot. Thanx a lot guys.
 
Old 02-28-2003, 12:31 PM   #7
watashiwaotaku7
Member
 
Registered: Oct 2002
Location: wisconsin -- The Badger state
Distribution: gentoo
Posts: 654

Rep: Reputation: 30
oh and if the install docs for an audigy look like some of the other install docs ive seen from alsa they will look very confusing, dont be discouraged they arent all that hard if you follow them step by step and of course members here will alwasy be willing to help you out
 
Old 02-28-2003, 01:50 PM   #8
Knytemare4
LQ Newbie
 
Registered: Feb 2003
Posts: 5

Original Poster
Rep: Reputation: 0
one more question...how would i recompile my kernel or unload my audigy module?
 
Old 02-28-2003, 07:20 PM   #9
watashiwaotaku7
Member
 
Registered: Oct 2002
Location: wisconsin -- The Badger state
Distribution: gentoo
Posts: 654

Rep: Reputation: 30
www.digitalhermit.com/linux/kernel.html

do the boot disk part then skip everything up to configuration if you feel like it then upgrade to a newer kernel...in which case do the whole thing, and if you do the mandrake kernel isnt quite normal so you cant patch it.

remove every option under sound except soundcore (thats the first option under sound) for the most part you should leave other things as they are, although if you know your system well you might deal with optimizing it for your processor
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Compaq IJ650 Install and SoundBlaster Audigy LS Install iScion Fedora 6 12-31-2004 04:15 AM
Yast2 Error message for SB Audigy; no sound LeanPudLou Linux - Newbie 1 08-17-2004 01:34 PM
Audigy 2 install merlin371 Linux - Hardware 0 04-29-2004 09:13 AM
SB Audigy LS (modprobe error) no such device fatboysmith Linux - Hardware 2 12-01-2003 09:24 PM
Help!! Audigy make install error... Linux-Newbie_71 Linux - Hardware 0 08-29-2002 09:44 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration