-   Linux - Newbie (
-   -   Attempting to run mplayer returns with error (

Matt.Ramos 07-19-2005 02:22 PM

Attempting to run mplayer returns with error

root@Internets:/home/matt# mplayer
mplayer: error while loading shared libraries: cannot open shared object file: No such file or directory

I am running Slackware 10.1 with compiled. I installed mplayer from I googled and searched on the forum for a while trying to find an answer, but I can't. Any help is greatly appreciated.


darkleaf 07-19-2005 02:32 PM

It's a codec. And mplayer can't find it. Doesn't it start at all? Then you have to find a codec package that has it in it. First place I'd look is the mplayer site and check the 'all codecs' package. If it just runs and you don't need the dv codec you can simply ignore it. The package is compiled to have that support that's why the error's there.

Matt.Ramos 07-19-2005 02:37 PM

When I run it from /usr/bin/ nothing happens, so that's why I went to Terminal. MPlayer's website has been down since this morning, possibly before that.

Should I compile it myself and not installpkg? Can you think of anything else it may be?

detpenguin 07-19-2005 02:44 PM

you need:

both available at


which are the codecs for most everything you'll watch....once it's untarred, it creates a directly called need to move that directory to /usr/local/lib and rename it codecs...that way mplayer will find them :)

which i know is available from the mplayer might find it someplace else if you google it, tho

Matt.Ramos 07-19-2005 02:56 PM

I downloaded and installpkg'd those 2 files, then I found the codecs and put them where they need to be. I renamed the folder, too.

I still get the same message when i type mplayer in Terminal.

detpenguin 07-19-2005 03:06 PM suggestion then, is to remove the mplayer.tgz version, and grab a tar.bz2 version and compile it for your box...thats the way i have mine running. if you want the gui version too, when you compile, type:

./configure --enable-gui

and that will set up GMPlayer for ya...

personally, i never got the .tgz version from linuxpackages to work on my box, but i thought maybe that was just me...anyways, thats my suggestion...hope it helps :)

Boow 07-19-2005 06:21 PM

Install from source then use checkinstall to make a package. The version from linuxpackages has alot of dependencies compiled in. run configure it will show you whats enabled and whats not. If you need something you'll have to get the package it needs and recompile.

Looks like mplayers website finaly got shutdown but I bet you can find the source on a gentoo mirror.

All times are GMT -5. The time now is 05:50 AM.