LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-06-2004, 09:18 PM   #1
MasterKin8T
Member
 
Registered: Jul 2003
Location: Maryland
Distribution: Slackware 9.1
Posts: 56

Rep: Reputation: 15
ATI driver problems


I've been having trouble getting the radeon driver to load instead of the mesa. I have been reading allot of making sure you have your kernal sources, which I do, but what am I supposed to do with them in relation to the ati driver? My kernel version is 2.4.24.

I followed the "ATI drivers How To" on linux-gamers.net to the T so im wondering what I did wrong. Everything is telling me it installed correctly yet when I check to see if direct rendering is on it says so, and when I check for opengl it says mesa instead of radeon. Anyone that has had this problem or any help at all would be greatly appreciated. I'll be up late attempting to fix this.

-Thanks

Last edited by MasterKin8T; 02-06-2004 at 09:24 PM.
 
Old 02-06-2004, 09:31 PM   #2
h/w
Senior Member
 
Registered: Mar 2003
Location: New York, NY
Distribution: Debian Testing
Posts: 1,286

Rep: Reputation: 46
and you DID go and edit ur config file for X to load the ATi driver with the options u want, right?

maybe u can give a little more info on what u did?
 
Old 02-06-2004, 09:41 PM   #3
MasterKin8T
Member
 
Registered: Jul 2003
Location: Maryland
Distribution: Slackware 9.1
Posts: 56

Original Poster
Rep: Reputation: 15
I do "modprobe fglrx" and it loads without any problems. I changed the

Option "UseInternalAGPGART" "yes"

to no. It will let me run glxgears but not fgl_glxgears. When I type in fglrxinfo it just says Mesa is loaded. Should I try uninstalling the Mesa moudles from /lib?
 
Old 02-06-2004, 09:52 PM   #4
trey85stang
Senior Member
 
Registered: Sep 2003
Posts: 1,091

Rep: Reputation: 41
is agpgart configured into yoru kernel or as a module? What distro are you running?
 
Old 02-06-2004, 10:04 PM   #5
MasterKin8T
Member
 
Registered: Jul 2003
Location: Maryland
Distribution: Slackware 9.1
Posts: 56

Original Poster
Rep: Reputation: 15
I am running RedHat 9, Im not positive if I have it as a module or builtin. Where would that be located under menuconfig?
 
Old 02-06-2004, 10:27 PM   #6
h/w
Senior Member
 
Registered: Mar 2003
Location: New York, NY
Distribution: Debian Testing
Posts: 1,286

Rep: Reputation: 46
heh, now let's wait for someone who uses ATi (cos i use nVidia) and can help you .
 
Old 02-06-2004, 10:50 PM   #7
trey85stang
Senior Member
 
Registered: Sep 2003
Posts: 1,091

Rep: Reputation: 41
try changing internal agpgart to no. RedHat by defualt will have agp as a module, next run

modprobe agpgart
&
modprobe fglrx

do the above from the CL, or if you do it with x running.. restart x (without rebooting)

post up if there are any errors.
 
Old 02-07-2004, 12:00 AM   #8
MasterKin8T
Member
 
Registered: Jul 2003
Location: Maryland
Distribution: Slackware 9.1
Posts: 56

Original Poster
Rep: Reputation: 15
This is what I get from trying to load agpgart

modprobe agpgart

/lib/modules/2.4.24/kernel/drivers/char/agp/agpgart.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.24/kernel/drivers/char/agp/agpgart.o: insmod /lib/modules/2.4.24/kernel/drivers/char/agp/agpgart.o failed
/lib/modules/2.4.24/kernel/drivers/char/agp/agpgart.o: insmod agpgart failed

Could this be from not having it loaded as a module in my kernel or not chaning the "yes" to "no" to "UseInternalAGPGART"


glxinfo | grep rendering

Xlib: extension "XFree86-DRI" missing on display ":0.0".
direct rendering: No

fglrxinfo

Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4


Last edited by MasterKin8T; 02-07-2004 at 12:03 AM.
 
Old 02-07-2004, 11:53 AM   #9
MasterKin8T
Member
 
Registered: Jul 2003
Location: Maryland
Distribution: Slackware 9.1
Posts: 56

Original Poster
Rep: Reputation: 15
bump
 
Old 02-09-2004, 04:19 PM   #10
Scavello
LQ Newbie
 
Registered: Jan 2004
Location: BC, Canada
Distribution: Fedora Core 4
Posts: 3

Rep: Reputation: 0
same issue

i am getting the same error trying to modprobe agpgart
im running redhat 9.2 on an nForce2 Ultra 400 w/ an Athlon 2500 and a Radeon 9600 Pro

PS what does "bump" mean?
 
Old 02-09-2004, 06:26 PM   #11
Kristijan
Member
 
Registered: Sep 2003
Location: Melbourne, Australia
Distribution: NetBSD 3.0.1, Slackware 10.1
Posts: 394

Rep: Reputation: 30
MasterKin8T I got the same output from the fglrxinfo command like you did. I followed the informaton from this topic http://www.linuxquestions.org/questi...hreadid=100220

Code:
kristijan@neo:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4
Since that topic is like a mini-how-to, check back there for results on my post, most likely they will affect you aswell

Happy hunting.

Scavello - 'bump' is just a word to move your topic to the top of the page so it is seen. That's all
 
Old 02-09-2004, 11:21 PM   #12
MasterKin8T
Member
 
Registered: Jul 2003
Location: Maryland
Distribution: Slackware 9.1
Posts: 56

Original Poster
Rep: Reputation: 15
I apprently didn't read the linux-gamers ATI HOW-TO well enough. For motherboards that use nForce you need to compile nVidia chip support in your kernel. After I did this I made sure to modprobe "fglrx" and "agpgart" BEFORE starting X. Afterwards when I ran fglrxinfo it told me I was using ATI instead of MESA.
 
Old 02-10-2004, 12:35 AM   #13
Kristijan
Member
 
Registered: Sep 2003
Location: Melbourne, Australia
Distribution: NetBSD 3.0.1, Slackware 10.1
Posts: 394

Rep: Reputation: 30
MasterKin8T could you please point me in the direction of the url you got the NForce information from. Or provide more details on how you did this. I too have a NForce 2 board.

Regards
Kristijan
 
Old 02-10-2004, 01:39 AM   #14
MasterKin8T
Member
 
Registered: Jul 2003
Location: Maryland
Distribution: Slackware 9.1
Posts: 56

Original Poster
Rep: Reputation: 15
I downloaded the latest 2.4 kernel (i admit, im scared of 2.6 since im a noob) and make sure that when I did "make menuconfig" I had nVidia chip support builtin. When I booted into the the kernel I was able to load agpgart and fglrx without it yelling at me (fglrx gave me a warning but nothing big, in fact the warning is normal acording to linux-gamers how to)

Just make sure you load everything before starting x. If you do "fglrxinfo" and its still showing mesa then something not being loaded before X.

It took me awhile to get everyhting straightened since im somewhat new to linux, let me know how it turns out.
 
Old 02-10-2004, 02:42 AM   #15
Kristijan
Member
 
Registered: Sep 2003
Location: Melbourne, Australia
Distribution: NetBSD 3.0.1, Slackware 10.1
Posts: 394

Rep: Reputation: 30
I seemed to have run into another problem.

I'm running 2.4.24 kernel. fglrx and agpgart modprobed fine without out any errors. When I change - Option "UseInternalAGPGART" "yes" to "no" in /etc/X11/XF86Config-4 and try and run glxgears, my whole screen goes black, and I have to reboot. Leaving Option "UseInternalAGPGART" "no", it works fine.

I also get this when trying to run fgl_glxgears
Code:
kristijan@neo:~$ fgl_glxgears
Error: couldn't get fbconfig
fglrxinfo still brings up the same results
Code:
kristijan@neo:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.3 Mesa 4.0.4
but...when I try to run fglrxinfo before X is started, it tells me that it is unable to open display.

So yeah, im in a bit of a rut here!

EDIT - Could you also point me to a URL of how you compiled nVidia chip support for your kernel, thanks

Last edited by Kristijan; 02-10-2004 at 02:45 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ATi Driver problems... a3Rogue Debian 5 09-18-2005 05:59 PM
ATI driver problems pyschomike15 Slackware 7 02-23-2005 07:15 PM
2.6.3 + ATI 3.7.6 driver problems marvin2k Linux - Hardware 3 03-16-2004 02:46 PM
ATI Driver Problems 54\/4g3 Linux - Hardware 1 01-16-2004 05:00 AM
ATI driver problems DRooGz Linux - Hardware 1 09-21-2003 02:20 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration