LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Asus Eee PC netbook - booting from a USB stick (https://www.linuxquestions.org/questions/linux-newbie-8/asus-eee-pc-netbook-booting-from-a-usb-stick-870921/)

EladLending 03-25-2011 08:00 AM

Asus Eee PC netbook - booting from a USB stick
 
Hi all. I'm trying to set up a netbook with Ubuntu for my computer-challenged Mother. I downloaded the image file to the download section of the new netbook, created a USB stick to boot from and then restarted the computer, pressing F2 in order to change the boot order. Using the "+" key I was able to put [Removable Dev.] on top: "1st Boot Device", but, and here's the thing, it is disabled: "A devince enclosed in the parenthesis has been disab led in the corresponding type menu." I do not understand this, nor do I know what to do. Help please....
Elad

elliott678 03-25-2011 08:04 AM

The easiest way is to tap Esc as the system is POSTing, then select your USB stick from the boot menu.

EladLending 03-25-2011 08:16 AM

Thank you Elliot
 
But I do not understand what you mean by Posting. Would you please elaborate?

brianL 03-25-2011 08:27 AM

I can't remember the exact wording, but on the Boot screen there's another option to select which drive is to be first. That has to be sorted out before the boot order option.

elliott678 03-25-2011 08:28 AM

When a computer turns on it does a Power On Self Test, commonly referred to as POST. That is when you see the Eee logo screen or if you have that disabled, you'd see some information about what is being done.

Press the power button and start tapping the Esc button and a boot menu will show up.

EladLending 03-25-2011 08:31 AM

Computer Details
 
Perhaps I should elaborate first:
The Computer is an Asus Eee PC netbook, operating on Windows 7 Starter. One enters the bios setup by pressing F2 during the boot. The problem is that even though I succeeded in moving the USB stick, referred to in Bios as 'Removable Dev.', I do not see how to change its status from 'disabled' to 'enabled'. Elad

repo 03-25-2011 08:34 AM

Try to press F9, it should present you a boot menu, then you can choose usb.

Kind regards

elliott678 03-25-2011 08:38 AM

Ignore the BIOS boot order, the boot menu overrides it temporarily, unless you want to boot from a USB stick every time it boots, changing it in the BIOS is not necessary. Just try it, instead of hitting F2 to go into the BIOS, hit Esc.

Every EeePC I've ever come across has the boot menu when you hit Esc, it is the easiest way to boot from a USB stick or SD card. I own two EeePCs, using a first generation EeePC 2g Surf right now, I've also got a 901, I've worked on probably a dozen others.

EDIT: F9 on an EeePC is the system recovery, not the boot menu.

EladLending 03-25-2011 08:38 AM

Ureka!
 
Thank you gentlemen. I got it! Now for my first experience with Ubuntu!

thom-ecliptic 06-08-2012 11:07 AM

Asus eee PC 1015BK
 
Hello
I have trouble making the same install here. My Asus came with Win 7 installed. I used unetbootin and created a USB stick with Linux Mint on it. I shut off the Asus and start while ESC, boot menu shows up, I choose the USB memory / or the USB via UEFI, the stick blinks some times, stops blinking and Windows gets loaded again. I dont understand this. Looks like the Linux on the USB is not bootable. But unetbootin should have created a bootable USB stick, or not?

Regards
Thom

thom-ecliptic 06-08-2012 03:28 PM

OK, I got it. Obviously, unetbootin does not work well on Mac OS X. I later did the same thing, creating a USB flash drive with unetbootin from an .iso file again, but this time I did it all on the Netbook Win7. And it worked. I finally decided for Ubuntu and installed it on the Netbook, eradicating Win7 as I hate everything M$ and need max. space for my files.

The next problem was: The netbook did not boot into the new installed Ubuntu. I started again using the flash drive, holding ESC to get to the boot loader screen and choose the USB drive to boot from. This worked and Ubuntu came up fairly quick. I did not see the flash drive blink again, so I suspected its in fact working from the HD installed ubuntu. Removing the flash drive was no problem.

Big problems for a longtime Mac user with no other OS experience. After some investigation I found out that probably Grub got installed on the flash drive instead of the HD. But how can I get it installed on the HD now? This page helped me solve it http://ubuntuforums.org/showthread.php?t=1581099 by using the terminal.

I run:
sudo dpkg-reconfigure grub-pc

Followed the dialogue (OK for all of them) until getting to choose which drive or partition to install Grub on. Neede quiet some trying around until I found I can choose a location by hitting the space bar, this puts a * in front of it. I choose both who showed up and then OK.

After that I had to run:
sudo grub-install --recheck /dev/sda
(sda is the main drive, other drives may be sdb or whatever)

And this one too:
sudo update-grub

After that, shut off the Netbook and start again, and it booted into Ubuntu.

First success!

Hope this may help out someone.
Thom

programs 01-31-2014 01:14 PM

EEE
 
Sorry about the resurrect but these netbooks see flash drives as HDDs so in order to change the boot in bios you need to change it in the HDD section.

EmmetC 03-07-2014 01:55 PM

My EeePC 1005-HA will not recognise a bootable USB stick (flash/thumb/pen drive) reliably if there are other bootable USB devices connected.

When I have a USB DVD drive connected — via a hub with other devices — and a bootable USB stick directly connected to another port, then hit ESC during POST, the list of bootable devices will always include the DVD drive, but only sometimes the USB stick. If the DVD drive is not plugged in, the USB stick appears in the boot menu every time.

gamerx_daniel 04-06-2014 12:20 PM

thanks! the F9 button worked for me.

FuzzyRev 04-29-2015 10:16 AM

Thank you!!!
 
I know this is an old post but it is still viable. Because of it, I was able to update the BIOS on this netbook - I was going nuts trying to get the flash drive to boot until you suggested the ESC key. THANK YOU.


All times are GMT -5. The time now is 06:19 PM.