LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Assign rights to directory (https://www.linuxquestions.org/questions/linux-newbie-8/assign-rights-to-directory-82223/)

robertmarkbram 08-15-2003 06:48 AM

Assign rights to directory
 
Howdy All!

I am using RedHat 9 with KDE..

I have mounted a vfat drive to a directory in my linux file system and when I run Konqueror as root, I can read and write files to it.. but I would like to give my normal login the rights to do that so I don't have to act as root.

As superuser, the permissions set on the directory are shown below:

dr-xr-xr-x 12 root root 16384 Jan 1 1970 BigBrain3

Any help would be most appreciated!

Rob
:)

robertmarkbram 08-15-2003 06:55 AM

btw.. I did try chmod as root:

[root@robertmarkbram java]# chmod 777 /BigBrain3/
chmod: changing permissions of `/BigBrain3/' (requested: 0777, actual: 0755): Operation not permitted

MasterC 08-15-2003 07:39 AM

Hello! I'm assuming you didn't do a search ;) You should give that a try as there are quite a few threads on this ;)

Ok, so the skinny (for more info, try a search for fat32 )
open your /etc/fstab locate the line corresponding to the partition, edit the umask settings to 000, save exit:
mount -a -o remount (or just reboot)

;)

Cool

yuray 08-15-2003 07:55 AM

Change the file /etc/fstab

you_disk you_mountdir vfat user,noauto 0 0

from usual user:
mount you_mountdir

and read the man mount for option user!

robertmarkbram 08-15-2003 07:58 AM

Thank you for the suggestion MasterC!

In fact, I did do a search.. but only with the terms "permanent mount".. which is what brought me here!

On your suggestion I did another search with "fstab mount permanent vfat" and found exactly what I was after:
http://linuxquestions.org/questions/history/55033

All I had to do was add this:
/dev/hda6 /BigBrain3 vfat defaults,umask=000 0 0
and everything is fine!

Thank you again!


All times are GMT -5. The time now is 04:21 PM.