LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Arch: error is failed to load vga, fbdev and nv module :doesnt exist (https://www.linuxquestions.org/questions/linux-newbie-8/arch-error-is-failed-to-load-vga-fbdev-and-nv-module-doesnt-exist-460267/)

flipwhy 07-02-2006 09:34 AM

Arch: error is failed to load vga, fbdev and nv module :doesnt exist
 
got arch on...downloaded xorg and gnome from pacman, added exec gnome-session to etc/X11/xinit/xinitrc (its the only line starting with exec) but when i type startx it says something like
"Failed to load module vga: doesnot exist."
same for fbdev and nv modules.
the only site with a reasonable soln wants money for it...
so...help!

JunctaJuvant 07-02-2006 09:46 AM

Arch Linux now uses the modular Xorg7, which means input and video drivers (the modules) are no longer automagically installed. See also: Arch Wiki
Hope that helps.

DeusExLinux 07-02-2006 11:43 AM

You will need to download the drivers specific to your hardware.. if you have hwd, you can use that to tell you which drivers you need.

Read the wiki page too, the Arch wiki has a lot of great documentation.

flipwhy 07-03-2006 10:43 AM

:Pengy: i downloaded nvidia and added it to the xorg.conf...but now it says failed to initialize the GLX module; and it also says
FreeFontPath: FPE '/usr/share/fonts/misc" refcount is 2, should be 1; fixing.

DeusExLinux 07-03-2006 12:25 PM

did you follow this http://wiki.archlinux.org/index.php/..._NVIDIA_driver ?

flipwhy 07-03-2006 05:32 PM

yes i did...
it also says xterm not found,dbus not found etc...

DeusExLinux 07-03-2006 08:19 PM

did you install them?

flipwhy 07-04-2006 05:18 AM

yes i did...
when i first ran startx...it showed none of those last errors except for the FPE one...the second time i did (without changing anything) it showed al those errors...
anyhow i queried pacman and it said xterm and dbus is installed but xclock and twm arent...tried to install them with pacman -Sy but it said they dont exist in the db.
Im very confused as to why its doing what its doing!:confused:

ethics 07-04-2006 06:29 AM

you dont have to have twm and xclock, they are programs being called when you run startx which chekcs your ~/.xinitrc

You could add the command to start gnome or kde or whatever instead

JunctaJuvant 07-04-2006 06:39 AM

I also recommend reading the Xorg page in the ArchWiki. If you want a complete desktop environment, like ethics suggested, there are pages in the ArchWiki that explain how to install KDE or Gnome.
In any case, if still you want all that xorg stuff, try the following:
Code:

# pacman -Sy xorg-twm xorg-apps

flipwhy 07-04-2006 07:57 AM

alright...
i tried the gnome desktop as explained on wiki...
i removed the xclock and twm..
it still says:
/etc/..../xinitrc line 32: exec: dbus: not found...
but dbus is instaled...
and it is in the xinitrc file...exec dbus...for gnome-session as in the wiki pages...

JunctaJuvant 07-04-2006 08:37 AM

From the wiki page:
Quote:

To start the correct processes at system startup, edit the file /etc/rc.conf and add "portmap", "fam", "dbus" and "hal" to the DAEMONS=() line.
Have you done that?

flipwhy 07-04-2006 09:44 AM

yes i did do that...

JunctaJuvant 07-04-2006 10:30 AM

And just to make sure, did you reboot? (the daemons array is only used during boot up)
Hope that helps.

DeusExLinux 07-04-2006 11:54 AM

if it's still giving you problems, what happens when you run (as root)
/etc/rc.d/hal restart

and


/etc/rc.d/dbus restart

?


All times are GMT -5. The time now is 04:32 AM.