LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Arabic letters (https://www.linuxquestions.org/questions/linux-newbie-8/arabic-letters-417677/)

CyberTroniX 02-20-2006 03:18 PM

Arabic letters
 
Hello everyone ,

My problem is in arabic letters , i cannot write in arabic and cannot read files or folders named in arabic , files and folder names appear like this : ???? ??? , and when i try to type a ltter in arabic i get a dotted box instead of each leter , but at the same time i can read arabic clearly on websites using Firefox .
This is a screenshot to understand how things appear .
http://www.freewebtown.com/shkhaled/snapshot1.jpg
I'm on Mandriva 2006 using KDE 3.4.2
And i have all these installed :
fonts-ttf-arabic-1.1-3mdk
fonts-ttf-arabic-arabeyes-1.1-1mdk
fonts-ttf-arabic-farsi-0.4-1mdk
fonts-ttf-arabic-kacst-1.6.3-1mdk
fribidi-0.10.4-5mdk
kde-i18n-ar-3.4.2-10mdk
libfribidi0-0.10.4-5mdk
locales-ar-2.3.5-1mdk
so i can't figure out what is missing or not installed to get it to read arabic .

Emerson 02-20-2006 03:31 PM

locale -a will show you what locales are supported by your current setup. Switching to unicode will solve problems like this forever and is suggested solution though.

CyberTroniX 02-20-2006 04:31 PM

i typed "locale -a" and i got lots of languages , these are from them and i think these are the arabic languages :
ar
ar_AE
ar_AE.UTF-8
ar_BH
ar_BH.UTF-8
ar_DZ
ar_DZ.UTF-8
ar_EG
ar_EG.UTF-8
ar_IN
ar_IN.UTF-8
ar_IQ
ar_IQ.UTF-8
ar_JO
ar_JO.UTF-8
ar_KW
ar_KW.UTF-8
ar_LB
ar_LB.UTF-8
ar_LY
ar_LY.UTF-8
ar_MA
ar_MA.UTF-8
ar_OM
ar_OM.UTF-8
ar_QA
ar_QA.UTF-8
ar_SA
ar_SA.UTF-8
ar_SD
ar_SD.UTF-8
ar_SY
ar_SY.UTF-8
ar_TN
ar_TN.UTF-8
ar_YE
ar_YE.UTF-8

so then how do i switch to unicode ?
(don't forget this is the Newbie section)

Emerson 02-20-2006 07:00 PM

If I only knew how it should be done in Mandriva/KDE. I assume it is fairly simple considering the nature of your distro and desktop environment.
You may look at this article and maybe this one helps too. KDE help might be useful too.

mangku 02-21-2006 05:14 PM

I don't use mandriver now but try this,Go to control centre, system,config system language and region, advanced,use unicode by default.

Or you could always look at Arabian linux, a new distro and not as mature and easy as mandriva. But you do get the arabic.

CyberTroniX 03-01-2006 02:41 PM

unfortunatly there is not config system language and region in the system section of the mandriva control center , so i cannot get to that point .

but i managed to found a language change option in :
open the menu > system > confgiuration > other > localdrake (user)
i had those languages only to choose from :
arabic
english
swati
uyghur
venda
and there was a checkbox for "use unicode by default"

i choose arabic and checked the check box , then i loged out then logged in again to find everything messed up , again i got a dotted box instead of everyarabic letter , so i swicthed it back to english .

also i have read the 2 articles on that link , but i cannot figure it out easily because i'm new to linux and mandriva

isn't there anybody out there that has managed to type and read arabic letters on mandriva/kde ??

i don't know what to do now !


All times are GMT -5. The time now is 04:19 PM.