LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-11-2005, 10:24 PM   #1
revenge80200
Member
 
Registered: Mar 2004
Location: Chicago
Distribution: Lenny & Xp
Posts: 238

Rep: Reputation: 30
apt-get upgrade errors


I cannot seem to find the answer to this one, any ideas you may have are welcome.

I installed java for both firefox and opera, though I am not sure if this is relevant to the problem, just where it started, after which I tried apt-get update and apt-get upgrade. The update was successful, where as the upgrade was not. I am prompted with the following error message:

Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
dpkg-preconfigure: cannot connect to X server :0.0

I have tried: apt-get -f upgrade and dpkg --configure -a, both to the same result. Furthermore, xhost +localhost as non-root and then trying the upgrade leads to the same thing.

Any ideas are welcome
Thanks for helping.
Eric.
 
Old 12-11-2005, 11:33 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,891

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
That looks like a common error if one tries to do something as root, without permission to use GUI while logged in as user. Try this:
logged in as user, open a console window and give this command: xhost + localhost
Then, su - to root, and start the application from the command line.

The 'su -' invokes the root environment instead of the users environment.

It seems to me that, in this instance, the root environment is the key.

It goes without saying, I'm not a guru. I've learned much in the last six years; I've so much more to learn. Occaissionly, I give good advice. Occaissionaly; not so good. But I try.

Last edited by bigrigdriver; 12-11-2005 at 11:37 PM.
 
Old 12-12-2005, 05:42 PM   #3
revenge80200
Member
 
Registered: Mar 2004
Location: Chicago
Distribution: Lenny & Xp
Posts: 238

Original Poster
Rep: Reputation: 30
Nice to see you again,

I've tried the xhost + localhost as you have suggesed only to get the same result. I've tried as well: dpkg --configure -a and apt-get -f upgrade with the following results, maybe something helpful in them you could spot that I have not.

linuxbox:/home/eric# apt-get -f upgrade
E: Could not get lock /var/cache/apt/archives/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the download directory

and

linuxbox:/home/eric# dpkg --configure -a
Setting up debconf (1.4.62) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process
dpkg: error processing debconf (--configure):
subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of xserver-common:
xserver-common depends on debconf (>= 1.0.21) | debconf-2.0; however:
Package debconf is not configured yet.
Package debconf-2.0 is not installed.
Package debconf which provides debconf-2.0 is not configured yet.

Any ideas?
Thanks for helping.
Eric.
 
Old 12-12-2005, 09:52 PM   #4
liamoboyle
Member
 
Registered: Mar 2004
Location: Wellington, New Zealand
Distribution: Debian
Posts: 127

Rep: Reputation: 15
It looks like another instance of apt-get is already running; only one can run at a tine and it creates a lock file in /var/cache/apt/archives/lock to ensure that another copy does not run accidentally. Check to see if any copies are running (ps aux | grep apt-get) and if they are kill them (killall apt-get; sleep 5; killall -9 apt-get) and try again.
 
Old 12-13-2005, 06:22 PM   #5
revenge80200
Member
 
Registered: Mar 2004
Location: Chicago
Distribution: Lenny & Xp
Posts: 238

Original Poster
Rep: Reputation: 30
Hummm, smells like progress to me. I gave it a spin, but something is still not working; here is the output:

linuxbox:/home/eric# ps aux | grep apt-get
root 5163 0.0 1.3 12180 10212 ? S Dec12 0:00 apt-get -f upgrade
root 6834 0.0 0.0 1860 620 pts/2 S+ 05:03 0:00 grep apt-get

linuxbox:/home/eric# killall apt-get; sleep 5; killall -9 apt-get
apt-get: no process killed

linuxbox:/home/eric# ps aux | grep apt-get
root 6839 0.0 0.0 1860 616 pts/2 R+ 05:03 0:00 grep apt-get

I looks like we got ride of one of them, if that is a good thing.

Thanks for helping out.
Eric.
\
 
Old 12-13-2005, 06:28 PM   #6
liamoboyle
Member
 
Registered: Mar 2004
Location: Wellington, New Zealand
Distribution: Debian
Posts: 127

Rep: Reputation: 15
Yep, you should be able to run the apt-get again now. Give it a go and show us the output.

FYI, killall sends a "polite" stop signal, which processes are free to ignore if they like, killall -9 sends a less polite "stop right now" signal which cannot be trapped by the process; they may still ignore it if they've gone zombie or are doing heavy IO, but it'll work for almost anything.
 
Old 12-13-2005, 07:51 PM   #7
revenge80200
Member
 
Registered: Mar 2004
Location: Chicago
Distribution: Lenny & Xp
Posts: 238

Original Poster
Rep: Reputation: 30
Well, it looks as though the 'puter has turned into a zombie then. I've tried killing it, the less polite of the two at that with these results:

linuxbox:/home/eric# apt-get upgrade
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
linuxbox:/home/eric# dpkg --configure -a
Setting up debconf (1.4.62) ...
Xlib: connection to ":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
frontend: cannot connect to X server :0.0
dpkg: error processing debconf (--configure):
subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of xserver-common:
xserver-common depends on debconf (>= 1.0.21) | debconf-2.0; however:
Package debconf is not configured yet.
Package debconf-2.0 is not installed.

I'm in the dark, any ideas?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gpg errors after apt upgrade (sid) darkleaf Debian 2 06-28-2005 09:22 AM
firestarter errors after apt-get upgrade Outabux Debian 2 03-03-2005 01:07 AM
Serious problem with apt-get dist-upgrade - encoutered fatal errors while upgrading! DarkLight Debian 3 08-06-2004 02:22 PM
apt-get dist-upgrade errors Pebcak Debian 4 06-15-2004 04:27 AM
apt-get upgrade print me errors coldy Debian 2 10-01-2003 08:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration