LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-24-2016, 03:02 PM   #1
crazy-yiuf
Member
 
Registered: Nov 2015
Distribution: Debian Sid
Posts: 119

Rep: Reputation: 51
apt-get - find out which package is requiring installations on upgrade


When I try to upgrade it wants to install the boost run time libraries. I would like to figure out which package wants them so I can remove it.

I was thinking of using --only-upgrade. Is there a smarter way? If I use --only-upgrade will it ignore the package with the dependency, or still try to upgrade it, resulting in a broken package?
 
Old 11-24-2016, 03:37 PM   #2
codix
LQ Newbie
 
Registered: Feb 2010
Posts: 14

Rep: Reputation: 4
Maybe aptitude why packagename is what you want.
 
1 members found this post helpful.
Old 11-24-2016, 04:00 PM   #3
crazy-yiuf
Member
 
Registered: Nov 2015
Distribution: Debian Sid
Posts: 119

Original Poster
Rep: Reputation: 51
I don't really want to install aptitude, either. Oh well, I ended up installing boost and checking the reverse dependencies. Time to go gripe to the freeorion devs about superfluous run time dependencies.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Make apt-get Installations and Upgrades 26x faster with apt-fast LXer Syndicated Linux News 1 10-25-2010 05:14 PM
selective apt-get upgrade package lrt Linux - Newbie 10 10-05-2010 09:23 AM
apt-get error. Could not find package deostroll Ubuntu 11 01-13-2008 04:19 AM
apt-rpm, SuSE 8.2 upgrade, and package conflicts bigrigdriver Linux - Software 2 05-28-2005 03:23 PM
Does apt-get install <package> upgrade the package if it is already installed? davidas Debian 4 04-05-2004 06:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration