LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-26-2012, 02:45 AM   #1
UTKA01
LQ Newbie
 
Registered: Jul 2012
Posts: 5

Rep: Reputation: Disabled
Apache2 Test page instead of Snorby panel.


Hi!
I am trying to built Snorby front-end for my test Snot IPS, but i am absolutely newbie in linux.
I used manual instructions of course and in end of it the following configurations of httpd.conf was suggested:

<VirtualHost *:80>
ServerAdmin admin@sext
ServerName sext
DocumentRoot /var/www/html/snorby/public

<Directory "/var/www/html/snorby/public">
AllowOverride all
Order deny,allow
Allow from all
Options -MultiViews
</Directory>
</Virtualhost>
Ok, i'v done it, checked my /etc/hosts/ - ok, restarted httpd, Tried on htpp://sext and get standart Apache2 Test page instead of Snorby panel.
I have checked /var/www/html/snorby/public directory,it is not empty, so and i doesnot get mesages about errors or something, just a standart apache test page.

Coul you help me to understand, for what possible reasons i see test page despite of configuration?
 
Old 07-26-2012, 03:03 AM   #2
smilemukul
Member
 
Registered: Jun 2009
Distribution: Redhat,CentOS,Ubuntu,Puppet
Posts: 292

Rep: Reputation: 34
you have to open the web page as, http://sext/snorby/public
 
Old 07-26-2012, 03:09 AM   #3
UTKA01
LQ Newbie
 
Registered: Jul 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
i have tried but 404 not found.
 
Old 07-26-2012, 03:28 AM   #4
smilemukul
Member
 
Registered: Jun 2009
Distribution: Redhat,CentOS,Ubuntu,Puppet
Posts: 292

Rep: Reputation: 34
modify AllowOverride None & then restart the httpd service & open the web page again as, http://sext/snorby/public

Also if this does'nt work then show the listing of files as, ls -l /var/www/html/snorby/public
 
Old 07-26-2012, 02:50 PM   #5
UTKA01
LQ Newbie
 
Registered: Jul 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
Modified, restarted, tried URL - everything the same.

ls -l :


total 40
-rw-r--r--. 1 root root 728 Jul 25 03:03 404.html
-rw-r--r--. 1 root root 711 Jul 25 03:03 422.html
-rw-r--r--. 1 root root 728 Jul 25 03:03 500.html
drwxr-xr-x. 2 root root 4096 Jul 25 03:03 assets
-rw-r--r--. 1 root root 0 Jul 25 03:03 favicon.ico
-rw-r--r--. 1 root root 1229 Jul 25 03:03 favicon.png
drwxr-xr-x. 2 root root 4096 Jul 25 03:03 flash
drwxr-xr-x. 11 root root 4096 Jul 25 03:03 images
drwxr-xr-x. 2 root root 4096 Jul 25 03:03 javascripts
-rw-r--r--. 1 root root 204 Jul 25 03:03 robots.txt
drwxr-xr-x. 3 root root 4096 Jul 25 03:03 stylesheets

I have been looking on content of public since yesterday, but had read plenty of manuals and seen no strings, that suggested to add something else in public directory. Only in config directory and i have done it.


I noticed once that it is report about no libyaml, installed it, reinstalled ruby, reports stopped but no other effect.


BTW output of apachectl start and stop keeps bothering me cause i see:

httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName

while uname -n shows sext, there is sext in /etc/hosts/ and etc/sysconfig/networking, but still...

Any idea?

Manuals i followed:
http://webcache.googleusercontent.co...&ct=clnk&gl=ru
and
https://github.com/Snorby/snorby/wik...bit-by-RISC427
 
Old 07-27-2012, 12:59 AM   #6
smilemukul
Member
 
Registered: Jun 2009
Distribution: Redhat,CentOS,Ubuntu,Puppet
Posts: 292

Rep: Reputation: 34
1. First of all you have to set owner & group as apache:apache of /var/www/html/snorby/public & set the permission as 744
2. Check your hostname & dnsdomainname whether they are same as what you had set.
3. Mention the entry of ipaddress in dns as,

@ IN NS <your hostname>.
www IN A <your eth0 ipaddress>
4. restart the httpd & named service & check /var/log/httpd/error_log
 
Old 07-28-2012, 11:09 AM   #7
UTKA01
LQ Newbie
 
Registered: Jul 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
smilemukul, and what if i have no dns server and just use hosts file for name resolution (this is my test lab for test tasks but not a production server)? Is that so apache needs dns server to start without errors?

1.I have set. Now i have 403 forbidden on http:/sext and http://sext/snorby/public and any othe directory in snorby, though that i used chown apache:apache /var/www/html/snorby/public and chmod 744 /var/www/html/snorby/public.
2.dnsdomainname is empty, i didn't set it and hostname is sext, ok. It seems to me that i have a normal message about absence of FQDN, but is that so apache cannot funtion properly without FQDN and this may cause my web aplication problems? Honestly i doubt it but who knows...
 
Old 07-29-2012, 07:12 AM   #8
UTKA01
LQ Newbie
 
Registered: Jul 2012
Posts: 5

Original Poster
Rep: Reputation: Disabled
Well.
I commented my VirtualDirectory section, uncomented default httpd server settings such as ServerName e.t.c. and after that was able and glad to see listing of public directory. Then i started rails s (who could even guessed :-P ) and snorby main page revealed itself. How nice

Last edited by UTKA01; 07-29-2012 at 07:15 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Make an Apache2 Login page? Silver565 Linux - Software 2 06-05-2009 05:11 AM
Apache2 - ab - stress test grant-skywalker Linux - Server 0 07-24-2007 06:45 AM
Help with Web Page Hosting and Apache2 Hambone_20003 Linux - Software 2 08-23-2005 09:31 PM
how do i test apache2? clueless_user Linux - Newbie 3 09-04-2004 04:11 AM
I cant change the default test page in apache server to add my page.y nhemapriya Linux - Newbie 3 05-13-2004 01:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration