Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 10-13-2009, 08:36 AM   #1
Registered: Aug 2009
Posts: 118

Rep: Reputation: 15
apache on linux

we installed apache(httpd-2.0.63) on red hat4.2 for proxy server.
when i tried to run, we got the error like

Syntax error on line 147 of /usr/local/apache2/conf/httpd.conf:
module auth_module is built-in and can't be loaded

our requirements are
In our local network(lan),the devloper type like
for accessing the applications
but we want,
whenever the user type the url like from the world,
it will automatically invoke the applications(

And also we bought SSL certificate.
How to enable the certificate in Newly installed apache.

we want Only https connection
Old 10-13-2009, 08:45 AM   #2
Senior Member
Registered: Mar 2004
Location: UK
Distribution: CentOS 6/7
Posts: 1,375

Rep: Reputation: 217Reputation: 217Reputation: 217
How did you install apache? Apache generally comes pre-installed in Red Hat so it sounds like you messed something up pretty badly there? at most you should have just done a yum install or yum update on it.

1. Sounds like your after port-forwarding. If they are browsing to the site just forward the port on the firewall/router. Else wise do a php forward to the ip or set the DNS entry at the DNS register with the port number on IP... I believe this can be done but not certain on it.

2. RHEL comes with openssl, I believe your going to have to look into that, I am afraid I can't guide you through this one, never set-up SSL to date tho will have to in the near future...

3. This will make the links in 1# not work, they'd have to be https you are aware of this? if so, just block port 80 in iptables for a simple way to do it, you can also change the listen ports in the apache configuration. There is probably a method to turn off just the http links in other ways but if your not listening to http traffic then you should still block port 80.
Old 10-13-2009, 07:18 PM   #3
LQ Guru
Registered: Aug 2004
Location: Sydney
Distribution: Centos 7.7 (?), Centos 8.1
Posts: 18,166

Rep: Reputation: 2680Reputation: 2680Reputation: 2680Reputation: 2680Reputation: 2680Reputation: 2680Reputation: 2680Reputation: 2680Reputation: 2680Reputation: 2680Reputation: 2680
For RHEL 4.x it's up2date; yum came in for v5.x. Here's a good x-ref and examples
I agree that using the RHEL pkg mgr is the way to go.
The RHEL Deployment guide
Sounds like you may want the mod_rewrite module for Apache to re-direct cxn to port 80 => 443.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache on Linux apogee General 8 10-02-2005 07:41 PM
New To Linux and Apache envyadi Member Intro 2 03-15-2005 03:32 PM
apache benchmarks (apache v13 / apache v20) ; large differences between benchmarking markus1982 Linux - Software 0 02-08-2003 10:53 AM
Apache on Linux 7.3 pbajpei Linux - Software 3 08-28-2002 06:25 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:23 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration