LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Apache Cgi-Bin confguration on debian distro (https://www.linuxquestions.org/questions/linux-newbie-8/apache-cgi-bin-confguration-on-debian-distro-205435/)

rjcmi 07-15-2004 01:03 PM

Apache Cgi-Bin confguration on debian distro
 
I'm attempting to install movable type on my personal apache server. I am currently unable to execute cgi scripts with my current apache configuration and would like to learn how i get apache to execute cgi scripts that are located withn /var/www/cgi-bin.

I beleive that I need to add/modify the httpd.conf file to make this happen, I'm just kind of lost as to what to add, or if i need to place my cgi scripts in a different location.

btmiller 07-15-2004 03:53 PM

Do you have a ScriptAlias directive pointing to your cgi-bin dir -- it would look something like:

ScriptAlias /cgi-bin/ "/var/www/cgi-bin"

and the access controls:

<Directory /var/www/cgi-bin>
AllowOverride None
Options None
Order allow,deny
Allow from all
</Direcory>

In general, make sure that you have all the packages you need to run CGI installed (as the default install may not have CGI support) -- you'll need to consult the Debian documentation for Apache to be sure.

rjcmi 07-15-2004 08:11 PM

Thanks for the help here is what my httpd.conf looks like:

ScriptAlias /cgi-bin/ /var/www/cgi-bin/

#
# "/usr/lib/cgi-bin" could be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
#
<Directory /var/www/cgi-bin/>
AllowOverride None
Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>
</IfModule>

and I uncommented the line
AddHandler cgi-script .cgi

Thanks again for the assist.


All times are GMT -5. The time now is 08:53 PM.