LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-12-2006, 09:22 PM   #1
bhert
Member
 
Registered: May 2006
Distribution: OpenSUSE 10.3 Kubuntu Hardy Heron
Posts: 268

Rep: Reputation: 30
Any good wmv players?


Hi. I installed wmv codecs to play wmv files in xine. Only a few wmv files worked when I played, most of the files were garbled or don't work at all. Is it an issue with Suse? If so, is there a better application that will allow wmv files to work properly? BTW the dvd movies work with xine. Help me find the right application so I don't need to use winblows to watch wmv files. Thanks

bhert
 
Old 08-12-2006, 09:30 PM   #2
puntjuh
Member
 
Registered: Apr 2006
Location: holland
Distribution: Gentoo / debian / suse / mint
Posts: 558

Rep: Reputation: 42
Perhaps this tutorial is something for you!

It's for SuSe 10.1 but it works for 10.0 as well.

suse wmv + dvd
 
Old 08-12-2006, 09:39 PM   #3
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 62
I normally thought the issue with garbled video require some kind of license key to be downloaded to view. It is normally downloaded automatically in media player under windows without you knowing. Not sure how to get it to work in Linux.

edit : After a short google search ( did not spend any real time on it) I found this info. Haven't time to try but give it try. There is more info in the link but here are the few post in it I found interesting. I would other saved message listed here as well. If any of this works post what you did.

http://sourceforge.net/mailarchive/f...ewmonth=200509

Code:
From: Adam Stein <adam@sc...>
Re: Xine can't load win32 codec  
2005-09-23 12:25

 I didn't get any responses, but I did eventually find out what was
 wrong.  I'm sending the solution back to the mailing list so that if
 anybody else has this problem, they can find this in the archives.
 
 After tracing through the source I found out that the config file is
 parsed so that anything after the colon (:) is saved, the whitespace
 isn't removed.  Instead of doing this (like I originally had):
 
 	decoder.external.win32_codecs_path: /path/to/codecs
 
 you need to have this
 
 	decoder.external.win32_codecs_path:/path/to/codecs
 
 Notice no whitepace after the colon.
 
 On Wed, 2005-09-21 at 13:37, Adam Stein wrote:
 > I'm running on a Linux RH9 system.  Xine lib v1.1.0, Xine UI v0.99.4. 
 > I've just tried the latest win32 codecs from the mplayer site.  The
 > problem is that xine can't seem to read the needed DLL file even though
 > it's available.  The only other relevant message I saw on the archives
 > had an answer about the codecs being built for 32-bit systems and the
 > person was most likely running a 64-bit system.  As far as I know, RH9
 > is running in 32-bit mode (is there even a 64-bit mode?)
 > 
 > I've installed the codecs on my system at
 > "/packages/xine/lib/win32-codecs".  I've set the following line in
 > $HOME/.xine/config:
 > 
 >   decoder.external.win32_codecs_path: /packages/xine/lib/win32-codecs
 > 
 > I ran xine with "--verbose=1" to get some diagnostic output.  If anybody
 > thinks it will help, I can post the entire verbose output.  What I think
 > is relevant is just this part:
 > 
 > gui_xine_open_and_play():
 >         mrl: '40.wmv',
 >         sub 'NONE',
 >         start_pos 0, start_time 0, av_offset 0, spu_offset 0.
 > xine: found input plugin  : file input plugin
 > xine: found demuxer plugin: ASF demux plugin
 > ffmpeg_audio_dec: increasing buffer to 98304 to avoid overflow.
 > wine/module: Win32 LoadLibrary failed to load: wmv9dmod.dll, 
 > /packages/xine/lib/win32-codecs/wmv9dmod.dll,
 > /usr/lib/win32/wmv9dmod.dll, /usr/local/lib/win32/wmv9dmod.dll
 > IMediaObject ERROR: 0x414c1b67  could not open DMO DLL (0x
 > ---------------------- (ERROR) ----------------------
 > A problem occur while loading a library or a decoder: wmvdmod.dll
 > ------------------ (END OF ERROR) -------------------
 > 
 > It lists the 'wmv9dmod.dll' file.  If I do a long listing on the 2nd
 > filename tried, I get:
 > 
 >  796 -rw-r--r--    1 adam     staff      807032 Nov 20  2002
 > /packages/xine/lib/win32-codecs/wmv9dmod.dll
 > 
 > so obviously the file exists, is readable by me (I own the file), and is
 > not an empty file.
 > 
 > I would appreciate any help.  If there is any other information that is
 > useful or something else I could try, just let me know.
 -- 
 Adam Stein @ Xerox Corporation       Email: adam@sc...
 
 Disclaimer: Any/All views expressed
 here have been proved to be my own.  [http://www.csh.rit.edu/~adam/]
 


			



From: Malte Gell <malte.gell@gm...>
Re: Xine can't load win32 codec  
2005-09-28 14:04

 On Wednesday 21 September 2005 19:37, Adam Stein wrote:
 
 > I've just tried the latest win32 codecs from the mplayer site.  The
 > problem is that xine can't seem to read the needed DLL file even
 > though it's available. 
 
 I recently had a similar problem, Xine 1.0.2/1.1.0 both stopped with a 
 SIGSEV signal. The codecs were placed at the right path. The problem 
 only occured with WMV video files.
 
 Setting a priority for that codec worked, I've set the following options 
 in ~/.xine/config
 
 engine.decoder_priorities.win32a:1
 engine.decoder_priorities.win32v:1
 
 After setting these options Xine works fine again with WMV videos!
 
 In your other posting you suggested to remove white spaces when setting 
 the path to the win32 codecs, I did this and it did not help, what 
 helped was to set a priority for the codec the way described above.
 
 Regards
 Malte
 


			



      From: Adam Stein <adam@sc...>
      Re: Xine can't load win32 codec  
      2005-09-29 04:07

       You had a different problem than I did.  I didn't core dump, Xine just
       told me it couldn't open the DLL file.  For some reason, I don't have to
       worry about priorities.  In my config file both priorities are set to
       0.  Never changed it and I can view WMV files just fine (as found on
       officeclips.com).  Strange that you would need it and I wouldn't.
       
       I wouldn't expect the removal of whitespace to help you as obviously,
       xine was reading in a DLL to use (it just happened to core dump I
       guess).
       
       On Wed, 2005-09-28 at 17:04, Malte Gell wrote:
       > On Wednesday 21 September 2005 19:37, Adam Stein wrote:
       > 
       > > I've just tried the latest win32 codecs from the mplayer site.  The
       > > problem is that xine can't seem to read the needed DLL file even
       > > though it's available. 
       > 
       > I recently had a similar problem, Xine 1.0.2/1.1.0 both stopped with a 
       > SIGSEV signal. The codecs were placed at the right path. The problem 
       > only occured with WMV video files.
       > 
       > Setting a priority for that codec worked, I've set the following options 
       > in ~/.xine/config
       > 
       > engine.decoder_priorities.win32a:1
       > engine.decoder_priorities.win32v:1
       > 
       > After setting these options Xine works fine again with WMV videos!
       > 
       > In your other posting you suggested to remove white spaces when setting 
       > the path to the win32 codecs, I did this and it did not help, what 
       > helped was to set a priority for the codec the way described above.
       > 
       > Regards
       > Malte
       -- 
       Adam Stein @ Xerox Corporation       Email: adam@sc...
       
       Disclaimer: Any/All views expressed
       here have been proved to be my own.  [http://www.csh.rit.edu/~adam/]
Brian1

Last edited by Brian1; 08-12-2006 at 09:40 PM.
 
Old 08-12-2006, 09:45 PM   #4
greengrocer
Member
 
Registered: Aug 2005
Distribution: Ubuntu Intrepid and Meerkat, formerly used Debian 3.1 (Sarge) with Gnome Desktop
Posts: 353

Rep: Reputation: 37
Have you configured the plug in directory correct for Xine?

If your using the Xine GUI, Try going into the settings of Xine and click the decoder tab, then set the correct path to where your Win32 codecs are located on your computer.

For example, I have the "W32codes_20050412-0unofficialubuntu2_i386.deb" package installed and the "mplayer codecs essential-20060611.tar.bz" unzipped into directory "/usr/local/lib/codecs"

I have the "path to Win32 codecs" for Xine pointing to /usr/local/lib/codecs


Every WMV file I throw at Xine works well with that setup. Maybe it will work for you too.

Of course Im using a Debian based distro, if your not using Debian based distro then you need to find an alternative RPM to the .deb package I quoted above.

Last edited by greengrocer; 08-12-2006 at 09:46 PM.
 
Old 08-12-2006, 11:03 PM   #5
bhert
Member
 
Registered: May 2006
Distribution: OpenSUSE 10.3 Kubuntu Hardy Heron
Posts: 268

Original Poster
Rep: Reputation: 30
I checked the paths for the codecs in xine menu and it was right the first time. It doesnt't give me an error about missing codecs, it just sits there with blue, green lines on the screen.

Brian, I changed the priority of the code in .xine/config, no go

I don't know what else to do.
 
Old 08-13-2006, 02:49 AM   #6
bhert
Member
 
Registered: May 2006
Distribution: OpenSUSE 10.3 Kubuntu Hardy Heron
Posts: 268

Original Poster
Rep: Reputation: 30
I forgot to post this. When I play wmv files, I could hear the sound but the video is just a blue and green block covering the screen. Is there a workaround for this?

bhert
 
Old 08-13-2006, 12:20 PM   #7
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
I don't know of a solution, but I can confirm that same problem. Maybe 33% of .wmv files play fine for me, another 33% have audio but no video, and the final 34% fail with a message about not having the proper codec. I find that interesting, as some of the .wmv files play just fine.

I am using totem in general, which is just a front end over xine IIRC. I do have all the current mplayer codecs installed in /usr/local/lib/codecs, and made symbolic links to them in /usr/lib/codecs, /usr/local/lib/win32 and /usr/lib/win32.

Eagerly awaiting any solutions for this.

Peace,
JimBass
 
Old 08-14-2006, 12:53 PM   #8
itisit9
LQ Newbie
 
Registered: Aug 2006
Posts: 3

Rep: Reputation: 0
I had that same problem, the tutorial link definately helped me out though.
 
Old 08-14-2006, 04:43 PM   #9
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
The tutorial unfortunately only applies to Suse. I'm having the same issues with debian. If it weren't solved by using a single distro solution only, it would have been of much more use to me.

Peace,
JimBass
 
Old 08-16-2006, 06:15 AM   #10
greengrocer
Member
 
Registered: Aug 2005
Distribution: Ubuntu Intrepid and Meerkat, formerly used Debian 3.1 (Sarge) with Gnome Desktop
Posts: 353

Rep: Reputation: 37
Yep, I had the same issues with WMV files, some would work fine, some wouldn't play at all and returned a missing codec error, and the remainder I got audio but no video.


If you follow my suggestions above, you will get all WMV files to work. I have not had any problem with WMV in Xine after I did what I suggested above.

I recommend to give what I suggested above a try, you may be pleasantly suprised.

Regards,
Greenie
 
Old 08-16-2006, 06:25 AM   #11
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 978

Rep: Reputation: 30
mplayer is a good choise or xine of course.
All the hints above are correct and there are something you have to adjust
for your performance therefor you will have to read the faqs on the xine webpage.
.. an other question ... wich video card you're using? and have you installed the latest drivers?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Any good MP3 players for rh9/1- Shrike? netmechDB Red Hat 4 11-27-2005 04:12 AM
Any good mp3-players? 3.14159 Linux - Software 9 12-15-2004 06:49 AM
Good morning, Good evening, Good night. Cheeseboy LinuxQuestions.org Member Intro 2 11-04-2004 10:46 PM
CD players Pedroski Mandriva 1 03-16-2004 03:30 PM
two, two, two cd players in one blistfix Linux - Newbie 3 07-03-2001 05:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration