LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Ancient Thinkpad running Mint 9 cannot get sound to endure re-boot (https://www.linuxquestions.org/questions/linux-newbie-8/ancient-thinkpad-running-mint-9-cannot-get-sound-to-endure-re-boot-848666/)

hexeta 12-06-2010 10:24 AM

Ancient Thinkpad running Mint 9 cannot get sound to endure re-boot
 
I think the title says it all really!
I'm a total newb, and absolutely lost in the Linux environment.
with the help of others (to whom grateful thanks), I've managed to get this distro installed and my PCMCIA Wireless card working without a LAN connection!
Result......well it was for me!
next big prob is sound.......any sound at all!
This command sudo modprobe snd-cs4236 sometimes gives me some, just for the current session, if it don't want to play, it just ignores me!
Two main questions,
1) How do I get the attention of the "Alsa Mixer"? (the GUI is normally just blank and may or may not be activated by the above command!)
2) Once I have the attention of the "Alsa mixer", how do I maintain it upon re-boot?

Some one guided me to this post and despite it's age, I appended my plea for help....but I fear it is not the correct place............I just hope I'm now in the right place!
http://www.linuxquestions.org/hcl/sh...hp/product/132

mlangdn 12-06-2010 10:38 AM

From a terminal as root, type this command:

Code:

# alsamixer
Press escape to get out . To store the new settings, again, in a terminal as root, type:

Code:

# alsactl store

snowday 12-06-2010 10:38 AM

I would suggest opening a Terminal (usually under Applications->Accessories or System Tools, not sure how Mint is structured) and running the following commands:

Code:

alsamixer
That should allow you to adjust your mixer settings.

Code:

sudo alsactl store
That should save the settings for next time.

As far as your module issue, that should be solvable by adding snd-cs4236 to /etc/modules

hexeta 12-06-2010 11:47 AM

Thanks guys for such a fast response.....I must have set something wrongly, 'cos I'm not getting any email advice of posts!

Because I don't know how to open a terminal as "root", I can't follow mlangdn's advice.
Tried that posted by snowpine with the following response from terminal: -
~ $ alsamixer
cannot open mixer: No such file or directory.
~ $ sudo alsactl store
alsactl: save_state:1502: No soundcards found...

Quote:

Originally Posted by snowpine
As far as your module issue, that should be solvable by adding snd-cs4236 to /etc/modules

What?...just typing it as an extra line on the existing page?? :confused:

On my travels around t' internet today, I found this: -
http://www.thinkwiki.org/wiki/Script...ip_in_PnP_mode but no idea if it is the right thing for my machine, or how to execute it.
I've asked for a helping hand there but no response so far

Just checked my settings and they are showing that I'm subsribed to this thread, and emails are enabled.....but it ain't happening!
I'll keep checking back regularly so I don't miss any one's posts!
Could do with Mod's attention to this problem.

snowday 12-06-2010 12:19 PM

On further investigation, it looks like Mint (since it is based on Ubuntu) probably uses PulseAudio instead of ALSA; that could explain the "cannot open alsamixer" error.

Sorry but I have no experience with PulseAudio.

/etc/modules is just a text file, you can edit it with "gksu gedit /etc/modules" and simply add a new line at the bottom for your sound module. (Unless Mint has some different/fancy way of doing things...)

hexeta 12-06-2010 12:30 PM

Thanks snowpine, but Mint 9 Lxde comes with Alsa mixer "out of the box" as they say! :)

PS: still no email notifications!
Where are the Mods??

snowday 12-06-2010 12:43 PM

Quote:

Originally Posted by hexeta (Post 4182475)
Thanks snowpine, but Mint 9 Lxde comes with Alsa mixer "out of the box" as they say! :)

I stand corrected, sorry. :)

Does it make a difference if you "sudo modprobe snd-cs4236" first?

GrapefruiTgirl 12-06-2010 01:05 PM

Quote:

Originally Posted by hexeta (Post 4182475)
Thanks snowpine, but Mint 9 Lxde comes with Alsa mixer "out of the box" as they say! :)

PS: still no email notifications!
Where are the Mods??

Hi there!

We got your report about the email notifications. Here's what I suggest, assuming your email address is correct and is the one you subscribed with:

1) Go to My Subscribed Threads" and click the checkbox beside this thread. Scroll to the bottom of the page, and using the little drop-down menu, select "Email Notification" and hit GO. That should fix it for this thread.

2) Go to your UserCP Edit Options" and scroll into the "Messaging and Notification" area and set your "Default Thread Subscription Mode" to whatever you desire. Scroll to the bottom of that page and select "Save Changes".

If this doesn't fix the issue, please contact me again by PM or email, and I'll look into this further.

Kind regards.
Sasha

hexeta 12-06-2010 01:09 PM

Quote:

Originally Posted by snowpine (Post 418248)
Does it make a difference if you "sudo modprobe snd-cs4236" first?

That's the command that I was told to use to kick start Alsa, because when it opens normally the GUI is just blank.
clicking on edit>Prog. prefs. brings up another window with some slider prefs.
edit>Sound card prefs. however just makes the whole thing disappear.

sometimes when I used "sudo modprobe snd-cs4236" it would unlock the GUI, other times it didn't...on those occasions, it was "listed" by Terminal as "used by 0 (Zero)".
On those occasions, I can't make it work at all.
Even when it does work, it dies when I shut down....but at least I now know that it should work :)

snowday 12-06-2010 01:12 PM

I don't understand your comments about "unlocking the GUI." Alsamixer is a terminal application. There is no clicking involved.

reed9 12-06-2010 01:15 PM

Quote:

Originally Posted by hexeta (Post 4182437)
Thanks guys for such a fast response.....I must have set something wrongly, 'cos I'm not getting any email advice of posts!

Because I don't know how to open a terminal as "root", I can't follow mlangdn's advice.
Tried that posted by snowpine with the following response from terminal: -
~ $ alsamixer
cannot open mixer: No such file or directory.
~ $ sudo alsactl store
alsactl: save_state:1502: No soundcards found...


What?...just typing it as an extra line on the existing page?? :confused:

You shouldn't run alsamixer as root. alsactl store is run with root privs, which you are doing by prefacing it with "sudo". It's saying there is no file or directory mixer? Sounds like you maybe didn't write alsamixer as all one word?

Yes, /etc/modules is just a text file. Adding the module name will force the module to load at boot. You can do so with any text editor (run with root privileges) or append as so from the terminal
Code:

echo "snd-cs4236" | sudo tee -a /etc/modules

reed9 12-06-2010 01:17 PM

Quote:

Originally Posted by snowpine (Post 4182521)
I don't understand your comments about "unlocking the GUI." Alsamixer is a terminal application. There is no clicking involved.

I assume the GUI referred to is the mixer GUI. Am I right in that if you don't load the module, the mixer is blank, when you load the module, it shows the normal mixer channels?

mlangdn 12-06-2010 01:49 PM

The sound card may not be configured. If that's the case, run:

Code:

# alsaconf
That does have to be ran as root.

Alsa will then configure your sound and load the proper module.

hexeta 12-06-2010 02:15 PM

Quote:

Originally Posted by snowpine (Post 4182521)
I don't understand your comments about "unlocking the GUI." Alsamixer is a terminal application. There is no clicking involved.

No, this is the blank GUI, and it shows the Programme preferences that I have described
When it's working right, the GUI has 8/10 slider controls for the various inputs and the master volume control
http://i53.tinypic.com/nnkwo7.jpg

snowday 12-06-2010 02:19 PM

I am not familiar with "GNOME ALSA Mixer" and cannot help you with it, sorry.

I am still unclear on what happens when you enter the following sequence of commands into the terminal (use copy & paste to avoid typos):

Code:

sudo modprobe snd-cs4236
alsamixer
sudo alsactl store

Please copy & paste the output of these commands if you would like my further assistance.


All times are GMT -5. The time now is 04:34 PM.