-   Linux - Newbie (
-   -   an inconsequential but strange bug (

joshknape 02-08-2006 10:45 PM

an inconsequential but strange bug
I have tried three distributions for a substantial length of time--Mandrake, Xandros (open circulation edition) and Knoppix (some build from mid-2005)--and in all three, I have run into a phenomenon which does not affect performance but obviously should not be there. The title bar (and very occasionally, the desktop and random applications) fill with various forms of gibberish. The gibberish usually consists of white-to-gray vertical bars or squares (in Mandrake and Xandros), but can sometimes consist of random letters (in Xandros). For some reason, it was much worse in Xandros than in the other two; the gibberish was bad enough to block what was on the screen at times, and I blamed Xandros (incorrectly, as I later figured out) and tried another distribution. I was most puzzled to notice, recently, that Knoppix has it too; that is very peculiar, because being a CD, it can't be corrupted by anything, can it?

Since this bug has appeared in three different distributions, I suppose someone else out there must have seen it too; but I can try to get a screenshot from Knoppix (that's the only thing I'm using right now) if needed.

foo_bar_foo 02-09-2006 12:32 AM

you have wrong video driver

amosf 02-09-2006 01:11 AM

Since you've seen it on a few distros it could be a hardware issue, or at least an issue that X has with your video hardware... What video chipset is it?

btmiller 02-09-2006 01:16 AM

Are you running KDE (sounds like it)? I noticed a similar problem off and on in the past. I have a cheap intel integrated graphics card, so perhaps that contributed. I haven't experienced the problem since upgrading to KDE 3.5.1. I suspect it to be a KDE/X/Video driver issue somewhere.

joshknape 02-09-2006 01:48 AM

Yes, my Knoppix and the other distros were running KDE. (I've never tried Gnome.) I'm afraid I am not sure how to identify the chipset in Linux (or in Windows, for that matter). But I am looking at the information for the display adapter in the Windows control panel (sorry, but I can't use the net in Knoppix and would be unable to type this message), and in several places, it says "Intel 82810."

amosf 02-09-2006 01:56 AM

intel 810 chipset... Yeah, not the best, but should work in 2D okay...

lspci would confirm what you have...

the X logs in /var/log would tell you stuff as well.

This might be a known issue, tho I used the 810 briefly in the past and didn't notice any problems...

All times are GMT -5. The time now is 06:28 AM.