-   Linux - Newbie (
-   -   An Error Occured While Mounting (

peterrust99 06-24-2012 12:51 AM

An Error Occured While Mounting
I am a newbie. I installed a new hdd (I think it's sdb1) and attempted to mount it using Storage Device Manager. I went off on a little adventure trying to get things mounted properly and changed some mount points I shouldn't have.

Now, when I reboot I get the error: "An error occured while mounting /media/File Press S to skip mounting or M for manual recovery". I think I may have created media/file as an incorrect mount point.

The following is now on my pc:

# /etc/fstab: static file system information.
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc nodev,noexec,nosuid 0 0
#Entry for /dev/sda6 :
UUID=07bd9cee-a261-44ae-96bf-41662cd675dc / ext4 errors=remount-ro 0 1
#Entry for /dev/sda5 :
UUID=88C8DA0DC8D9F980 /media/data ntfs-3g defaults,locale=en_US.UTF-8 0 0
#Entry for /dev/sda1 :
UUID=AA7434A2743472E5 /media/File System ntfs-3g defaults,locale=en_US.UTF-8 0 0
#Entry for /dev/sda7 :
UUID=30694711-0914-48eb-ae93-14792c377281 none swap sw 0 0

/dev/sdb1 / ntfs defaults 0 0
"/etc/fstab" 16 lines, 827 characters

I have output from sudo bash which I ran when I first set up linux if that's any help.

Any assistance would be appreciated. Thanks.

pan64 06-24-2012 02:48 AM

this is the last line:
/dev/sdb1 / ntfs defaults 0 0
You wrote sdb is your new drive, you cannot mount it to /.

peterrust99 06-24-2012 07:36 AM

I think I changed /dev/sda1 mount point to something incorrect. What should the mount point be for this? Also, I guess I can change the mount point for /dev/sdb1 (I assume this is my new hdd) to anything I want?

I have output from sudo bash which I ran when I first set up linux if that's any help.


pan64 06-24-2012 08:07 AM

actually / is the root filesystem, you cannot mount your new drive as your root filesystem. I suggest you to find a convenient directory, for example /photos or /mydatafolder or /mymedia/music. You must take care about any configured automounter (so probably /media/music will not work if /media was used by automounter).

frankbell 06-24-2012 09:30 PM

This is the best tutorial I have found on fstab. I recommend it highly.

peterrust99 06-25-2012 12:05 PM

Thanks for the information about the fstab tutorial. I'm a newbie but I think I may have made some progress. I looked at the setup when I first set up linux. According to blkid output, my primary hard drive was /dev/sda. After I installed the second hard drive my fdisk -l shows my primary hard drive (The one linux mint boots from) as /dev/sdb. However the current fstab shows my primary hard drive as being /dev/sda. Apparently I made some incorrect moint points because of this mix up and using storage device manager didn't help things much.
Anyway, I think the solution is to edit fstab and use the UUID. I may be way off base here. Can anybody concur?

pan64 06-25-2012 12:35 PM

yes, uuid should work

peterrust99 06-26-2012 02:05 PM

I created a new mount point, mounted sdb1 and changed fstab to reflect the change. that solved it. Thanks.

markomi 07-01-2012 04:18 AM

Hi everybody,a got a same problem....
Whet i install Linux Ubuntu,I added my backup hard drive,but a can't read NTFS partition....
Then I installed NTFS Configuration Tool,for this,i don'n now whats gona happen,but every boothing I got "An error occured while mounting/media/sdb...?
How to fix this problem?....Thanks

All times are GMT -5. The time now is 06:25 PM.