LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   aMSN and LibTCL8.4 (https://www.linuxquestions.org/questions/linux-newbie-8/amsn-and-libtcl8-4-a-561045/)

Guilherme 06-11-2007 10:38 PM

aMSN and LibTCL8.4
 
Hello.
One thing I would like to have in MSN (actualy i am using kopete) is the microphone and webcam functionality, so I saw somewhere that aMSN can make it...
I decided to download it and compile it ...
Acording with the dependencies I compiled TCL8.4 and TK8.4, everything ok untill here, although with TK I couldn't compile it, anyway I used RPM (it worked nicely). I runned "./configure && make && make install" as well as and it finish well... so I runned the same command to aMSN and everything ok ...
But, when I run "amsn" this is reported to me:
Code:

Application initialization failed: Can't find a usable init.tcl in the following directories:
    /usr/lib/tcl8.4 /usr/lib/tcl8.4 /lib/tcl8.4 /usr/library /library /tcl8.4.11/library /usr/lib/tcl8.4



This probably means that Tcl wasn't installed properly.

Error in startup script: can't find package Tk
    while executing
"package require Tk"
    (file "/usr/bin/amsn" line 48)

I am actualy unsing Mandriva 2006 with KDE.

I gone to /lib directory, maybe the libtcl could be something like libtcl8.4 .. but there is nothing at all...

could you help me please? how can I fix it

Thanks ;)

DiBosco 06-12-2007 04:00 AM

My understanding is aMSN will only work with cam and not mic. The bleeding edge stuff which has best cam support is the svn stuff, youd be best off installing that if you can work out how to compile and not just install an rpm. I'm using aMSN on 2007.1 and the cam works very well. Hopefully they'll add audio.

On the tcl issue, I had this too on one of my installations. IIRC, I went to control centre | software manager and installed a tcl-devel rpm which did the trick. I found this after much Googling!

Guilherme 06-12-2007 10:46 AM

ok ... it is working... thank you a lot..

By the way, I tryed to use Skype and it reports me soundcard error when I try to make a call... althohg it worked before, a long time ago with other Mandriva instalation.
The application detects the card "Creative Sound Blaste Live!" on all the ways, input/output and alarms...
For sometime ago I had this error when I was trying to record a sound "Device /dev/dsp does not exists" ... I googled a lot and nothing...

What is this?? :D

Thanks


All times are GMT -5. The time now is 03:18 AM.