-   Linux - Newbie (
-   -   amixer alsamixer I don't have a mixer (

lackluster 06-17-2002 07:44 PM

amixer alsamixer I don't have a mixer
I think I have alsa insalled properly, but I need just a little help to get going. Here's what I have:


# lsmod
Module Size Used by
snd-pcm-oss 17920 0 (autoclean)
snd-pcm-plugin 14096 0 (autoclean) [snd-pcm-oss]
snd-mixer-oss 4672 0 (autoclean) [snd-pcm-oss]
snd-card-als4000 2064 0 (autoclean)
snd-opl3 4432 0 (autoclean) [snd-card-als4000]
snd-hwdep 3024 0 (autoclean) [snd-opl3]
snd-als4000 12944 0 (autoclean) [snd-card-als4000]
snd-pcm 31360 0 (autoclean) [snd-pcm-oss snd-pcm-plugin snd-als4000]
snd-timer 8976 0 (autoclean) [snd-opl3 snd-pcm]
snd-mixer 23840 0 (autoclean) [snd-mixer-oss snd-als4000]
snd-mpu401-uart 2672 0 (autoclean) [snd-card-als4000
snd-rawmidi 10336 0 (autoclean) [snd-mpu401-uart]
snd-seq-device 3840 0 (autoclean) [snd-rawmidi]
snd 32608 1 (autoclean) [snd-pcm-oss snd-pcm-plugin snd-mixer-oss snd-card-als4000 snd-opl3 snd-hwdep snd-als4000 snd-pcm snd-timer snd-mixer snd-mpu401-uart snd-rawmidi snd-seq-device]
ipt_MASQUERADE 1312 1 (autoclean)
ipt_LOG 3232 13 (autoclean)
ipt_state 608 11 (autoclean)
ip_nat_ftp 3216 0 (unused)
iptable_nat 14144 2 [ipt_MASQUERADE ip_nat_ftp]
ip_conntrack_ftp 3376 0 [ip_nat_ftp]
ip_conntrack 14736 3 [ipt_MASQUERADE ipt_state ip_nat_ftp iptable_nat ip_conntrack_ftp]
natsemi 15584 1 (autoclean)
mousedev 3920 1
ne2k-pci 4784 1
ppp_generic 17024 0 (unused)
slhc 4512 0 [ppp_generic]

#cat /proc/asound/sndstat
Sound Driver:3.8.2-980706 (ALSA v0.5.12a emulation code)
Kernel: Linux cj50748-c 2.4.18 #13 SMP Sat Jun 15 03:36:24 EDT 2002 i686
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
Avance Logic ALS4000 soundcard, DSP v3.2 at 0xdc00 irq 10

Audio devices:
0: ALS4000 (DUPLEX)


Midi devices:
0: MPU-401 (UART)

7: system timer

0: ALS4000
I ran snddevices and got this :

# ./snddevices
Creating /dev/mixer?... done
Creating /dev/sequencer... done
Creating /dev/midi?... done
Creating /dev/dsp?... done
Creating /dev/audio?... done
Creating /dev/sndstat... done
Creating /dev/music... done
Creating /dev/dmmidi?... done
Creating /dev/dmfm?... done
Creating /dev/amixer?... done
Creating /dev/adsp?... done
Creating /dev/amidi?... done
Creating /dev/admmidi?... done
create symbolic link `/dev/mixer' to `/dev/mixer0'
create symbolic link `/dev/midi' to `/dev/midi0'
create symbolic link `/dev/dsp' to `/dev/dsp0'
create symbolic link `/dev/audio' to `/dev/audio0'
create symbolic link `/dev/sequencer2' to `/dev/music'
create symbolic link `/dev/adsp' to `/dev/adsp0'
create symbolic link `/dev/amidi' to `/dev/amidi0'
ALSA dynamic sound device filesystem
create symbolic link `/dev/snd' to `/proc/asound/dev'
ALSA loader devices
Creating /dev/aload?... done
Creating /dev/aloadSEQ... done
(I know this is alot of crap, but here's my point)

Now! When I run amixer I get this :

# amixer
amixer: Mixer attach default error: No such file or directory

I run alsamixer and get this:

# alsamixer

alsamixer: function snd_ctl_open failed for default: No such file or directory

What have I done wrong? Or haven't done? I know alot of people have gotten the alsa drivers to work on their machine, but I can't get it right. When I googled, I kept getting answers like run the snddevices script, did you run the snddevices script, have you tried the snddevices script and so forth. Please help! Thanks a million :).

Oh, and my modconf looks like this:


alias net-pf-4 off # we won't use PF IPX
alias net-pf-5 off # we won't use PF AppleTalk
alias eth0 8139too
alias eth1 natsemi
alias snd-card0 snd-card-als4000
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-slot-0 snd-card-als4000
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-12 snd-pcm-oss

lackluster 06-17-2002 10:20 PM

oh, and I don't know if this matters or not, but KDE's kMix (like all the other KDE multimedia apps) just fakes about loading, then disappears off into the pool of dead apps.

lackluster 06-21-2002 10:03 PM

Ok, forget about this, I have another comp with Mandrake. Same problem except I have devfs and it's an Intel AC'97 on-board card.

MasterC 06-22-2002 03:05 AM

Try aumix, or gmix
See if they also trail off
Just open an Xterm and type it in

lackluster 06-22-2002 09:47 AM

well, the mandy comp dosen't seem to have these mixers :(, but my slack comp had gmix (didn't try aumix - was too excited) and it WORKED! :) :) :) :) That's awesome! THanks! Now I have hope for the mandy comp :) Thanks alot, MasterC.

MasterC 06-23-2002 02:33 AM

Glad I could help...

My mandy has all 3, I don't know what package they would be in though. Let me see if I can poke around and find out for ya.

MasterC 06-23-2002 02:36 AM

That's for mandy, it's the aumix

All times are GMT -5. The time now is 02:34 PM.