LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Am I using the b43 driver? Shouldn't I be using b43legacy?? (https://www.linuxquestions.org/questions/linux-newbie-8/am-i-using-the-b43-driver-shouldnt-i-be-using-b43legacy-654686/)

thatwaschrislee 07-09-2008 05:05 PM

Am I using the b43 driver? Shouldn't I be using b43legacy??
 
using:
slackware 12.1
kernel 2.6.24.5
P4M processor, Gateway 7320GZ laptop

I have been trying to get my broadcom 4306 working using the b43-fwcutter tool. I extracted the firmware into /lib/firmware for both the b43 and b43legacy drivers but iwlist scanning would return something like no scan results. This was not right. I noticed lspci -vv returned "Kernel modules: bcm43xx, ssb". The bcm43xx module was never loaded though. Nonetheless, I added it to my modules.d blacklist and rebooted. The lspci command returned the same but all of a sudden my wireless was working. Now I am confused what happened and would like to find out. I am pasting some output of relevant commands. My questions are:

- What driver am I using?

- Why is b43 or b43legacy not mentioned in my lspci output?

- 4306 cards with a MAC core revision of 4 or less are supposed to use b43legacy but my system always autoloads the b43 module. Does the "(rev 03)" in the lspci output not refer to MAC core revision?

Thanks very much for any clarification!

chris
:)

NOTE: install instructions found at http://linuxwireless.org/en/users/Drivers/b43

$ lspci -vv
...
01:09.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
Subsystem: Broadcom Corporation Unknown device 0418
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 64
Interrupt: pin A routed to IRQ 17
Region 0: Memory at e00f6000 (32-bit, non-prefetchable) [size=8K]
Kernel driver in use: b43-pci-bridge
Kernel modules: bcm43xx, ssb

$ lsmod | grep b43
b43 113568 0
rfkill 9488 3 rfkill_input,b43
mac80211 122124 1 b43
led_class 7300 1 b43
input_polldev 7304 1 b43
ssb 32516 1 b43
pcmcia 35884 2 b43,ssb
pcmcia_core 35988 4 b43,yenta_socket,rsrc_nonstatic,pcmcia

$ dmesg | grep b43
b43-phy0: Broadcom 4306 WLAN found
input: b43-phy0 as /devices/virtual/input/input9
Registered led device: b43-phy0:tx
Registered led device: b43-phy0:rx
Registered led device: b43-phy0:radio

$ dmesg | grep bcm
returns nothing

$ lsmod | grep bcm
returns nothing

XavierP 07-11-2008 04:33 AM

I have, from memory, the same card and have the same drivers as you. I discovered, on an Ubuntu or Debian forum, that you need to edit one of the udev rules to get it to work. I can't recall the rule, but basically you have to remove the line which loads the wireless driver and then reboot. When the system reboots it rewrites the rule and works. I'm at work so can't get the data right now, but try a search for b43-fwcutter debian or b43-fwcutter ubuntu.

thatwaschrislee 07-11-2008 10:05 PM

Hi Xavier,
Thanks for the reply, but the chip seems to be working. The problem I have is I don't know why or how!?

Any ideas on that sort of thing?

chris

fedoralinuxjunkie 07-12-2008 02:03 AM

Hey thatwaschrislee.

Have you tried using NDISWrapper? I could never get my Broadcom cards to work with the b43 drivers or the bcm43xx-fwcutter...

XavierP 07-12-2008 07:23 AM

Both the ssb and the b43 modules were loaded when you installed. By blacklisting one, you allowed the other to start working - they were likely conflicting and making the connection fail. Funnily enough, the posts I read when trying to get my card working all said to blacklist ssb - but if it works for you, leave it alone :)

thatwaschrislee 07-15-2008 02:16 PM

Xavier, I agree with you on your "if it's not broken, leave it alone" advice but I still see some inconsistent performance. Sometimes I boot up my computer and internet is not working. Rebooting usually fixers the problem. This is getting worse since I installed a webcam. The webcam is a Logitech Quickcam Pro for Laptops using the uvcvideo and snd_usb_audio modules. This is why I would like to better understand why my wireless chip is not being loaded as a b43legacy as linuxwireless.org states.

I have since also tried blacklisting b43 to see if b43legacy gets loaded at startup but no luck. Nothing is loaded for the wireless.

any other ideas/resources?/

thanks,
chris


All times are GMT -5. The time now is 05:38 AM.