-   Linux - Newbie (
-   -   always problem in installing (

pxy20 05-27-2006 10:35 PM

always problem in installing
i was trying to install a gtk+-1.2.10-52.fc6.i386.rpm, but it announced me
"Failed dependencies: is needed by gtk+-1.2.10-52.fc6.i386"
then i found the glibc-2.3.5-10.i386.rpm in and tried to install it, it had this error
"Failed dependencies:
glibc-common = 2.3.5-10 is needed by glibc-2.3.5-10.i386
glibc > 2.3.4 conflicts with glibc-common-2.3.4-2.9.i386"
so i download the glibc-common-2.3.5-10.i386.rpm and tried to install it. it has the error
"error: Failed dependencies:
glibc < 2.3.5 conflicts with glibc-common-2.3.5-10.i386"

i also tried to rebuild a source rpm"glibc-2.3.6-3.src.rpm"
this error occurs
"/usr/bin/ld: cannot find -lintl
collect2: ld returned 1 exit status
make[2]: *** [/usr/src/redhat/BUILD/glibc-2.3.6/alinux/elf/dl-allobjs.os] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/glibc-2.3.6/elf'
make[1]: *** [elf/subdir_lib] Error 2
make[1]: Leaving directory `/usr/src/redhat/BUILD/glibc-2.3.6'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.17444 (%build)

RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.17444 (%build)

it seems that i cant intall the file
whatever can i do to fix the problem?

my system is RHEL4
i used the command "rpm -qa|grep glibc"
it had the result

masonm 05-27-2006 11:03 PM

Try installing all of the development packages. That should provide you with the libraries you need.

pxy20 05-28-2006 09:40 PM

thanks for your advice
I tryed many different glibc packages, but it still can not work out.

more over, i found i can't upgrade my system without the

can u give me some further advices?

Electro 05-28-2006 09:55 PM

I do not like recommending a Linux distribution that will fix your problems, but Gentoo is golden when these problems occure in other distributions.

If you still want use RHEL 4, try using apt-get or yum to help you gather the dependencies. If it can gather the dependencies, I recommend backing up your installation. When something goes wrong during or a program glitches more than you think from the upgrade, then you can restore your system from the backup and forget the upgrade. Hopefully, you test the backup before upgrading the library.

BobNutfield 05-29-2006 03:30 AM


I had this same problem a while back. What is happening is that you are trying to install software that is not meant for your distrobution (my problem occurred when I tried to install software for FC5 in FC4). only recently was released for FC5. If you will notice the version of GTK you are trying to install is for fc6, which is still in development and will be for some time yet as FC5 was only released in March. Many of the freatures of RHEL4 are the result of testing in FC3 and FC4. Fedora is considered the testing ground for RHEL and many of the components of the FC5 will appear in the next release of RHEL.

Hope this helps


pxy20 05-29-2006 05:15 AM

thanks a lot!
I found another GTK+ rpm, and finally the GTK installing problem was worked out.

BUT after I installed gtk+-1.2.10-39, the system still announced me that
"configure: error: *** GTK+ >= 1.2.2 not installed - please install first ***"

I used the rpm -q command, and I got the result "gtk+-1.2.10-39"

I think may be it is due to some environment variable problem.

can any of u tell me how to fix it?

timmeke 05-29-2006 05:41 AM

Do you have more details on the error reported by "configure"?

Also, since you've installed gtk+ (what you wanted in the first place), why are you still
running a "configure" tool? What else are you trying to compile from source & install?

I doubt that your environment vars have anything to do with the error. More likely, rpm installed gtk+ in a place that's different from where "configure" expected to find it.

pxy20 05-29-2006 05:48 AM

thanks for your attention.

here are the details:
I was trying to install xmms-1.2.10.tar.gz
when i was using the ./configure command, i got the error

"checking for gtk-config... no
checking for GTK - version >= 1.2.2... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.
configure: error: *** GTK+ >= 1.2.2 not installed - please install first ***

but I do installed gtk+-1.2.10-39.
thanks in advance

timmeke 05-29-2006 06:10 AM

Try doing a:

whereis gtk-config
That should tell you where the gtk-config utility is installed.
Setting the $GTK_CONFIG environment variable to that full path should do the trick.

As an alternative solution, you could play around with the "-prefix" option of "configure".
ie if gtk+'s binaries are installed in
/usr/bin, you could specify -prefix=/usr and/or put /usr/bin in your $PATH, as suggested.
To find out where rpm installed the gtk+ programs, try doing:

rpm -q --filesbypkg gtk+
That'll show you which files where installed from the gtk+ rpm.

pxy20 05-29-2006 10:28 AM

The problem has drove me crazy.
I tried "whereis gtk-config", but no path return back.
then I tried "rpm -q gtk", I can got "gtk-1.2.10-885"
and I tried "rpm -q gtk+" and got " gtk+-1.2.10-39"

I also tried "whereis gtk", I got "gtk: /etc/gtk /usr/lib/gtk". I explored these two folders, I can't find the gtk-config either, but i find a file "gtkrc", whose type is "GTK CONFIGURATION". then i tried "export GTK_CONFIG=/etc/gtk/gtkrc ". However, i still got erorrs

timmeke 05-30-2006 03:17 AM

The /etc/gtk/gtkrc file is probably a config file containing settings for GTK. It's not a program in itself, so it
can't be the gtk-config program you're looking for.

gtk-config should be in /usr/bin. At least, it is on my old RedHat 8 box.

rpm -q gtk yields nothing for me.
rpm -q gtk+ says that gtk+-1.2.10-22 is installed, which is older than your version.

Your "whereis gtk" output worries me a bit. It only indicates a gtk library and a config directory (under /etc). It doesn't find any
programs (ie under /bin, /usr/bin, etc). I'm thinking that maybe you don't have the complete GTK+ package and thus may need to install some

Try finding out what was installed in the gtk and gtk+ rpms, by using:

rpm -q --filesbypkg gtk
rpm -q --filesbypkg gtk+

The first will tell us what's in the gtk rpm (I don't have it installed, so I'm wondering if it can conflict with your gtk+ installation).
The second will check the files installed from your gtk+ rpm. Post it's output, or try to find any executable programs
(ie in /bin, /usr/bin), especially keeping an eye out for "gtk-config".

Maybe a

whereis gtk+
might help too.

antus 11-27-2007 02:47 AM

gtk-config is in the gtk+-devel package

All times are GMT -5. The time now is 05:19 AM.