LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   alsa not working (https://www.linuxquestions.org/questions/linux-newbie-8/alsa-not-working-84405/)

Hampster 08-21-2003 11:33 PM

alsa not working
 
I'm trying to follow the random train of thoughts that the alsa website calls instructions. (Did James Joyce write them?)

Anyway, I get to the point where I type
Code:

./configure --with-cards=opl3sa2 --with-sequencer=yes
everything seems O.K. though, except towards the end:
Code:

checking cross compile...
checking for directory with kernel source... /lib/modules/2.4.20-19.9/build
checking for kernel version... The file /lib/modules/2.4.20-19.9/build/include/linux/version.h does not exist.
Please, install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /usr/src/linux).

I haven't a clue what this means, or what to do about it. The first time I installed Linux, it detected the sound card and I didn't have to do a thing.

-Dave

exodist 08-21-2003 11:49 PM

you need to install the kernel sources package (there is an rpm on one of the cd's) or you need to d-load the kernel source from www.kernel.org
then extarct in /usr/src/
enter the directory it makes and type this:
make mrproper
make menuconfig
---hit left arrow and hit exit saving changes (even though you made none)
make dep
make clean

now try alsa.

Hampster 08-23-2003 11:01 AM

By kernel source package, I take it you mean the raw source. The first time I booted into RH9, it informed me there was a newer kernel for me, which was automatically downloaded and installed. So, I doubt there will be anything on the cd.

I will probably need to do a bit of research before I'm able to follow your instructions. I havent' used Linux since the RH5 days, and I was never able to administer a computer before. I've been in OSX land since then.

-Dave

Hampster 08-23-2003 12:00 PM

So, thanks to exodist, I was able to get a bit further. I'm almost done, I am supposed to type 'mod-probe snd-opl3sa2' but I get an error: modprobe: Can't locate module snd-opl3sa2

However:
Code:

[root@StFroggy modules]# find /usr/src -name 'snd-opl3*'
/usr/src/alsa/alsa-driver-0.9.6/drivers/opl3/snd-opl3-lib.o
/usr/src/alsa/alsa-driver-0.9.6/drivers/opl3/snd-opl3-synth.o
/usr/src/alsa/alsa-driver-0.9.6/isa/snd-opl3sa2.o
/usr/src/alsa/alsa-driver-0.9.6/modules/snd-opl3-lib.o
/usr/src/alsa/alsa-driver-0.9.6/modules/snd-opl3-synth.o
/usr/src/alsa/alsa-driver-0.9.6/modules/snd-opl3sa2.o

It appears to me that things are good. Does the .o extension mean a module? I've tried '/sbin/modprobe ./snd-opl3sa2.o' from the modules directory, but I get the same error. What is the next step?

Thanks, Dave

exodist 08-24-2003 02:35 AM

sorry I didn't respond sooner, lots of issues, most resolved.


All times are GMT -5. The time now is 08:36 PM.